tools/ppl: Update to 1.2
[openwrt/openwrt.git] / tools / flex / Makefile
index 8e32ace854e6c5cc500f4e59bea82b59d8281134..78eb1e0b460814f4ab5bb3dc173caab243440c7a 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,16 +7,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
-PKG_VERSION:=2.5.35
+PKG_VERSION:=2.6.1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=10714e50cea54dc7a227e3eddcd44d57
-PKG_CAT:=bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/westes/flex/releases/download/v$(PKG_VERSION)/
+PKG_MD5SUM:=cd3c86290fc2676a641aefafeb10848a
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += -static
+HOST_CONFIGURE_ARGS += --disable-shared
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall