flex: Add a lex symlink
[openwrt/openwrt.git] / tools / flex / Makefile
index 1398b1ae51a5273fcca71504c7a3893243e8368c..bb5aecbdfeadeef0f3803c6e9678b1de5a31978e 100644 (file)
@@ -7,6 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
+PKG_CPE_ID:=cpe:/a:flex_project:flex
 PKG_VERSION:=2.6.4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -20,6 +21,11 @@ include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)