uboot-envtools: drop executable file attribute from files/ipq
[openwrt/openwrt.git] / tools / gmp / Makefile
index ca80415bc863e5a8f76d3c7577ab6418ac59e5c4..0a0816287455e6b5da1524613135b935519dc239 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=5.1.2
+PKG_VERSION:=6.1.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_MD5SUM:=06fe2ca164221c59ce74867155cfc1ac
+PKG_HASH:=d36e9c05df488ad630fff17edb50051d6432357f9ce04e34a09b3d818825e831
 
 HOST_FIXUP:=autoreconf
 
@@ -24,7 +24,12 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --disable-assembly \
        --enable-cxx \
        --enable-mpbsd
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
 $(eval $(call HostBuild))