gmp: disable assembly to fix build on systems that use PIE binaries
[openwrt/openwrt.git] / tools / gmp / Makefile
index 292d9a5b3aec2ab62fa77373ddb247f6b33022a8..fac05e356820e0d7dd92f567e15b9d9e1d02d928 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=5.0.5
+PKG_VERSION:=5.1.3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_MD5SUM:=8aef50959acec2a1ad41d144ffe0f3b5
+PKG_MD5SUM:=e5fe367801ff067b923d1e6a126448aa
+
+HOST_FIXUP:=autoreconf
 
 HOST_BUILD_PARALLEL:=1
 
@@ -22,7 +24,12 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --disable-assembly \
        --enable-cxx \
        --enable-mpbsd
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
 $(eval $(call HostBuild))