tools/firmware-utils: add header version 2 support for mktplinkfw
[openwrt/openwrt.git] / tools / gmp / Makefile
index ca80415bc863e5a8f76d3c7577ab6418ac59e5c4..fac05e356820e0d7dd92f567e15b9d9e1d02d928 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=5.1.2
+PKG_VERSION:=5.1.3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_MD5SUM:=06fe2ca164221c59ce74867155cfc1ac
+PKG_MD5SUM:=e5fe367801ff067b923d1e6a126448aa
 
 HOST_FIXUP:=autoreconf
 
@@ -24,7 +24,12 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --disable-assembly \
        --enable-cxx \
        --enable-mpbsd
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
 $(eval $(call HostBuild))