tools/libressl: bump to v3.5.3
[openwrt/openwrt.git] / tools / libressl / Makefile
index 27f8496fdbeec5be8c68b248db85bd875792321c..236a7c2c307510b9589fdee896c798530ec5de3f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2016 LEDE project
+# Copyright (C) 2016-2017 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,27 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libressl
-PKG_VERSION:=2.5.0
-PKG_HASH:=8652bf6b55ab51fb37b686a3f604a2643e0e8fde2c56e6a936027d12afda6eae
+PKG_VERSION:=3.5.3
+PKG_HASH:=3ab5e5eaef69ce20c6b170ee64d785b42235f48f2e62b095fca5d7b6672b8b28
 PKG_RELEASE:=1
 
+PKG_CPE_ID:=cpe:/a:openbsd:libressl
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mirror.ox.ac.uk/pub/OpenBSD/LibreSSL \
        http://ftp.jaist.ac.jp/pub/OpenBSD/LibreSSL \
-       http://ftp.openbsd.org/pub/OpenBSD/LibreSSL
+       https://ftp.openbsd.org/pub/OpenBSD/LibreSSL
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOSTCC := $(HOSTCC_NOCACHE)
+HOST_CONFIGURE_ARGS += --enable-static --disable-shared --disable-tests
+HOST_CFLAGS += $(HOST_FPIC)
+
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += --disable-asm
+endif
+
 $(eval $(call HostBuild))