tools/m4: update 1.4.18
[openwrt/openwrt.git] / tools / m4 / Makefile
index 6470a549a59a3e128b4f2397ce7a73a4fde1d0ec..aa3c382f5bb38b7a4aacdfcc6dc36bbdb17b90d5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,16 +7,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=m4
-PKG_VERSION:=1.4.16
+PKG_VERSION:=1.4.18
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=a5dfb4f2b7370e9d34293d23fd09b280
-PKG_CAT:=zcat
+PKG_HASH:=f2c1e86ca0a404ff281631bdc8377638992744b175afb806e25871a24a934e07
+PKG_CAT:=xzcat
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOST_CONFIGURE_VARS += gl_cv_func_strstr_linear=no
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall