tools/mpfr: remove bogus configure override
[openwrt/openwrt.git] / tools / mpfr / Makefile
index 5abb2a2c792ea587c3624212930daf1fea731d1a..13ee63a6a71a468788b68c3cbd1fede7b4a54d94 100644 (file)
@@ -7,35 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=2.3.2
+PKG_VERSION:=3.0.0
 
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-2.3.2
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
+PKG_MD5SUM:=f45bac3584922c8004a10060ab1a8f9f
 
 
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --with-gmp=$(STAGING_DIR_HOST) \
-       );
-endef
+HOST_FIXUP:=autoreconf
 
 
-define Host/Compile
-       make -C $(HOST_BUILD_DIR) all
-endef
-
-define Host/Install
-       make -C $(HOST_BUILD_DIR) install
-endef
+include $(INCLUDE_DIR)/host-build.mk
 
 
-define Host/Clean
-       rm -rf $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --with-gmp=$(STAGING_DIR_HOST)
 
 $(eval $(call HostBuild))
 
 $(eval $(call HostBuild))