tools/libressl: Update to 2.5.1
[openwrt/openwrt.git] / tools / mpfr / Makefile
index 2a23f9738792264306db29c17cf1cd784368a560..91b5986f6c3f7c0d88f0313bd9e01dc73d9beb2c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=3.0.0
+PKG_VERSION:=3.1.5
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=f45bac3584922c8004a10060ab1a8f9f
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION) \
+               @GNU/mpfr
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_HASH:=015fde82b3979fbe5f83501986d328331ba8ddf008c1ff3da3c238f49ca062bc
+
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/host-build.mk