brcm63xx: use relocate to move the kernel back to start of ram
[openwrt/openwrt.git] / tools / ppl / Makefile
index 7eea73f0b0c7e5bb735641de3ebf5b531ea22f34..082b200e4aee1a5993b392650f3a537173203be3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppl
-PKG_VERSION:=0.10.2
+PKG_VERSION:=1.1
 
-PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=e7dd265afdeaea81f7e87a72b182d875
+PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=82617a9c4e08606111ed9d2dc37ececa
+
+HOST_FIXUP:=autoreconf
+
+HOST_BUILD_PARALLEL:=1
+HOST_CONFIGURE_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -29,5 +34,4 @@ define Host/Configure
        )
 endef
 
-
 $(eval $(call HostBuild))