iperf3: add SSL variant for iperf_auth feature
[openwrt/openwrt.git] / tools / sstrip / Makefile
index f978eae2647f333f5df9d3e10fc27a30300d6eca..180bd1743e5d6402707504ba1dfddb126867af29 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,27 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sstrip
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
 
 include $(INCLUDE_DIR)/host-build.mk
 
-OS:=$(shell uname)
-ifeq ($(HOST_OS),Darwin)
-  CFLAGS += -I./include
-endif
-CFLAGS += -I $(TOPDIR)/tools/include -include endian.h
-
-define Build/Compile
-       $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+define Host/Compile
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
 endef
 
-define Build/Install
-       mkdir -p $(STAGING_DIR)/bin
-       $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR)/bin/
+define Host/Install
+       $(CP) $(HOST_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
 endef
 
-define Build/Clean
-       rm -f $(STAGING_DIR)/bin/sstrip
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/sstrip
 endef
 
 $(eval $(call HostBuild))