tools: Fix cmake build on FreeBSD 10.1
[openwrt/openwrt.git] / tools / xorg-macros / Makefile
index 020dadb0794e70c44a2bcf039ffe8b5f0039a9f7..54df4028e9307bf6cb773a9adc6d9a7864c6f7a4 100644 (file)
@@ -1,29 +1,26 @@
-# 
+#
 # Copyright (C) 2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xorg-macros
 PKG_VERSION:=1.11.0
 
-PKG_SOURCE:=util-macros-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://cgit.freedesktop.org/xorg/util/macros/snapshot/
-PKG_MD5SUM:=2bb2645cfc2cc6768dd46f9406cab1d7
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/individual/util/
+PKG_SOURCE:=util-macros-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=22d5cdff672450cb6902e0d68c200dcb
 
-HOST_BUILD_DIR:=$(BUILD_DIR)/util-macros-$(PKG_VERSION)
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/util-macros-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Compile
-       ( cd $(HOST_BUILD_DIR); ./autogen.sh )
-endef
-
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR)/host/share/aclocal
-       $(INSTALL_DATA) $(HOST_BUILD_DIR)/xorg-macros.m4 $(STAGING_DIR)/host/share/aclocal/
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+       $(INSTALL_DATA) $(HOST_BUILD_DIR)/xorg-macros.m4 $(STAGING_DIR_HOST)/share/aclocal/
 endef
 
 define Host/Clean