ramips: Fix sysupgrade for Xiaomi mir3g
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 5 Jan 2020 14:10:06 +0000 (15:10 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 5 Jan 2020 19:05:33 +0000 (20:05 +0100)
Without this change sysupgrade from 18.06 to 19.07 is only possible with
the -F option.
In OpenWrt 18.06 the nand_do_platform_check() function is called with
the board name mir3g only, if the tar does not use mir3g it will fail.
OpenWrt 19.07 and later support the metadata with the supported_devices
attribute to allow renaming. Do the renaming of the target between 19.07
and master like it is done for some other boards.

I tested the following sysupgrades successfully without -F
18.06 -> 19.07
19.07 -> master
master -> 19.07

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ramips/image/mt7621.mk

index 7eb59188fb482b84ab76518a55d6daca9302ccaa..39017a48e106a37b0c031c3c5cc41eff8f024d8a 100644 (file)
@@ -269,7 +269,7 @@ define Device/xiaomi_mir3p
 endef
 TARGET_DEVICES += xiaomi_mir3p
 
-define Device/xiaomi_mir3g
+define Device/mir3g
   DTS := MIR3G
   BLOCKSIZE := 128k
   PAGESIZE := 2048
@@ -282,12 +282,12 @@ define Device/xiaomi_mir3g
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   DEVICE_TITLE := Xiaomi Mi Router 3G
   SUPPORTED_DEVICES += R3G
-  SUPPORTED_DEVICES += mir3g
+  SUPPORTED_DEVICES += xiaomi,mir3g
   DEVICE_PACKAGES := \
        kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic \
        uboot-envtools
 endef
-TARGET_DEVICES += xiaomi_mir3g
+TARGET_DEVICES += mir3g
 
 define Device/mt7621
   DTS := MT7621