libs/ncurses: update to 6.0
authorp-wassi <p.wassi@gmx.at>
Sat, 10 Dec 2016 19:23:24 +0000 (20:23 +0100)
committerJohn Crispin <john@phrozen.org>
Tue, 20 Dec 2016 08:35:36 +0000 (09:35 +0100)
Update libncurses to upstream release 6.0

Signed-off-by: Paul Wassi <p.wassi@gmx.at>
package/libs/ncurses/Makefile
package/libs/ncurses/patches/100-ncurses-5.6-20080112-urxvt.patch
package/libs/ncurses/patches/101-ncurses-5.6-20080628-kbs.patch
package/libs/ncurses/patches/102-ncurses-5.9-gcc-5.patch
package/libs/ncurses/patches/103-fixup-pkg-config-handling.patch [deleted file]
package/libs/ncurses/patches/500-cross.patch
package/libs/ncurses/patches/900-terminfo.patch

index b1fe2747cca7042b6ae49b6a3f3dc735e1f8a3e2..5b31d593f1b028a759412456c6532dfa44f4434f 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncurses
-PKG_VERSION:=5.9
-PKG_RELEASE:=4
+PKG_VERSION:=6.0
+PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/ncurses
-PKG_HASH:=9046298fb440324c9d4135ecea7879ffed8546dd1b58e59430ea07a4633f563b
+PKG_HASH:=f551c24b30ce8bfb6e96d9f59b42fbea30fa3a6123384172f9e7284bcf647260
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=README
@@ -63,6 +63,7 @@ CONFIGURE_ARGS += \
        --with-shared \
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo \
+       --with-pkg-config-libdir=/usr/lib/pkgconfig \
        --enable-widec \
        --with-build-cppflags=-D_GNU_SOURCE
 
@@ -130,10 +131,10 @@ define Build/InstallDev
        ln -s . $(1)/usr/include/ncursesw
        $(TARGET_CROSS)ar rc $(1)/usr/lib/libtinfo.a
        $(INSTALL_DIR) $(2)/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw6-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
-               $(2)/bin/ncursesw5-config
-       ln -sf $(STAGING_DIR)/host/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
+               $(2)/bin/ncursesw6-config
+       ln -sf $(STAGING_DIR)/host/bin/ncursesw6-config $(1)/usr/bin/ncursesw6-config
 endef
 
 define Host/Compile
index 20a6b43c15d3e8346a60a515df0225b13344c3cf..49537b94eee92b17308ff80bed1f03d21f179834 100644 (file)
@@ -1,7 +1,7 @@
 --- a/misc/terminfo.src
 +++ b/misc/terminfo.src
-@@ -4208,6 +4208,172 @@ rxvt-cygwin-native|rxvt terminal emulato
- rxvt-16color|xterm with 16 colors like aixterm,
+@@ -5214,6 +5214,172 @@ rxvt-cygwin-native|rxvt terminal emulato
+ rxvt-16color|rxvt with 16 colors like aixterm,
        ncv#32, use=ibm+16color, use=rxvt,
  
 +# rxvt-unicode
 +      fsl=\007,
 +      dsl=\E]2;\007,
 +
+ #### MRXVT
  # mrxvt 0.5.4
  #
- # mrxvt is based on rxvt 2.7.11, but has by default XTERM_FKEYS defined, which
index 779fa44bd2a7e70d19c9bd03feaa1443046cd40e..394b6f9fde989f28c276708bcf9716b4a5321e9b 100644 (file)
@@ -1,14 +1,14 @@
 --- a/misc/terminfo.src
 +++ b/misc/terminfo.src
-@@ -3274,6 +3274,7 @@ xterm-xfree86|xterm terminal emulator (X
+@@ -3955,6 +3955,7 @@ xterm-xfree86|xterm terminal emulator (X
  # This version reflects the current xterm features.
  xterm-new|modern xterm terminal emulator,
        npc,
 +      kbs=\177,
-       indn=\E[%p1%dS, kDC=\E[3;2~, kEND=\E[1;2F, kHOM=\E[1;2H,
-       kIC=\E[2;2~, kNXT=\E[6;2~, kPRV=\E[5;2~, kb2=\EOE,
-       kcbt=\E[Z, kcub1=\EOD, kcud1=\EOB, kcuf1=\EOC, kcuu1=\EOA,
-@@ -4061,6 +4062,7 @@ mlterm-256color|mlterm 3.0 with xterm 25
+       indn=\E[%p1%dS, kb2=\EOE, kcbt=\E[Z, kent=\EOM,
+       rin=\E[%p1%dT, use=xterm+pcfkeys, use=xterm+tmux,
+       use=xterm-basic,
+@@ -5048,6 +5049,7 @@ mlterm-256color|mlterm 3.0 with xterm 25
  rxvt-basic|rxvt terminal base (X Window System),
        OTbs, am, bce, eo, mir, msgr, xenl, xon, XT,
        cols#80, it#8, lines#24,
@@ -16,7 +16,7 @@
        acsc=``aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~,
        bel=^G, blink=\E[5m, bold=\E[1m, civis=\E[?25l,
        clear=\E[H\E[2J, cnorm=\E[?25h, cr=^M,
-@@ -4071,7 +4073,7 @@ rxvt-basic|rxvt terminal base (X Window
+@@ -5058,7 +5060,7 @@ rxvt-basic|rxvt terminal base (X Window
        enacs=\E(B\E)0, flash=\E[?5h\E[?5l, home=\E[H, ht=^I,
        hts=\EH, ich=\E[%p1%d@, ich1=\E[@, il=\E[%p1%dL, il1=\E[L,
        ind=^J, is1=\E[?47l\E=\E[?1l,
@@ -25,7 +25,7 @@
        kcbt=\E[Z, kmous=\E[M, rc=\E8, rev=\E[7m, ri=\EM, rmacs=^O,
        rmcup=\E[2J\E[?47l\E8, rmir=\E[4l, rmkx=\E>, rmso=\E[27m,
        rmul=\E[24m,
-@@ -4840,6 +4842,7 @@ eterm-color|Emacs term.el terminal emula
+@@ -6118,6 +6120,7 @@ eterm-color|Emacs term.el terminal emula
  screen|VT 100/ANSI X3.64 virtual terminal,
        OTbs, OTpt, am, km, mir, msgr, xenl, G0,
        colors#8, cols#80, it#8, lines#24, ncv@, pairs#64, U8#1,
        acsc=++\,\,--..00``aaffgghhiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~,
        bel=^G, blink=\E[5m, bold=\E[1m, cbt=\E[Z, civis=\E[?25l,
        clear=\E[H\E[J, cnorm=\E[34h\E[?25h, cr=^M,
-@@ -4849,7 +4852,7 @@ screen|VT 100/ANSI X3.64 virtual termina
-       cvvis=\E[34l, dch=\E[%p1%dP, dch1=\E[P, dl=\E[%p1%dM,
-       dl1=\E[M, ed=\E[J, el=\E[K, el1=\E[1K, enacs=\E(B\E)0,
-       flash=\Eg, home=\E[H, ht=^I, hts=\EH, ich=\E[%p1%d@,
--      il=\E[%p1%dL, il1=\E[L, ind=^J, is2=\E)0, kbs=^H, kcbt=\E[Z,
-+      il=\E[%p1%dL, il1=\E[L, ind=^J, is2=\E)0, kcbt=\E[Z,
-       kcub1=\EOD, kcud1=\EOB, kcuf1=\EOC, kcuu1=\EOA,
-       kdch1=\E[3~, kend=\E[4~, kf1=\EOP, kf10=\E[21~,
+@@ -6128,7 +6131,7 @@ screen|VT 100/ANSI X3.64 virtual termina
+       dl=\E[%p1%dM, dl1=\E[M, ed=\E[J, el=\E[K, el1=\E[1K,
+       enacs=\E(B\E)0, flash=\Eg, home=\E[H, ht=^I, hts=\EH,
+       ich=\E[%p1%d@, il=\E[%p1%dL, il1=\E[L, ind=^J, is2=\E)0,
+-      kbs=^H, kcbt=\E[Z, kcub1=\EOD, kcud1=\EOB, kcuf1=\EOC,
++      kcbt=\E[Z, kcub1=\EOD, kcud1=\EOB, kcuf1=\EOC,
+       kcuu1=\EOA, kdch1=\E[3~, kend=\E[4~, kf1=\EOP, kf10=\E[21~,
        kf11=\E[23~, kf12=\E[24~, kf2=\EOQ, kf3=\EOR, kf4=\EOS,
-@@ -4955,6 +4958,7 @@ screen.xterm-r6|screen customized for X1
+       kf5=\E[15~, kf6=\E[17~, kf7=\E[18~, kf8=\E[19~, kf9=\E[20~,
+@@ -6252,6 +6255,7 @@ screen.xterm-r6|screen customized for X1
  # on Solaris because Sun's curses implementation gets confused.
  screen.teraterm|disable ncv in teraterm,
        ncv#127,
index 5e33492bf53917551c07da3bc88c95dffb2c94a5..0424b237819795fa7be5ab1fe572783704299450 100644 (file)
@@ -15,7 +15,7 @@ Subject: [PATCH] ncurses 5.9 - patch 20141206
 
 --- a/ncurses/base/MKlib_gen.sh
 +++ b/ncurses/base/MKlib_gen.sh
-@@ -437,11 +437,22 @@ sed -n -f $ED1 \
+@@ -491,11 +491,22 @@ sed -n -f $ED1 \
        -e 's/gen_$//' \
        -e 's/  / /g' >>$TMP
  
diff --git a/package/libs/ncurses/patches/103-fixup-pkg-config-handling.patch b/package/libs/ncurses/patches/103-fixup-pkg-config-handling.patch
deleted file mode 100644 (file)
index 85b2296..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-Change handling of PKG_CONFIG_LIBDIR
-
-When PKG_CONFIG_LIBDIR was unset in the environment, the configure
-script was deducing the PKG_CONFIG_LIBDIR from the location of the
-pkg-config binary, which doesn't make a lot of sense, and isn't done
-by other autotools based packages.
-
-Also, the configure script was checking that the directory really
-exists. This forced to create the directory *and* provide an absolute
-path in PKG_CONFIG_LIBDIR, which didn't play well with the fact that
-at installation time, PKG_CONFIG_LIBDIR is suffixed to DESTDIR, which
-means that we got two times the staging directory location.
-
-This patch fixes both of those issues. Also, since ncurses uses a fork
-of autoconf 2.13, we can't simply use _AUTORECONF=YES, so we also fix
-the configure script in this patch.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
---- a/configure
-+++ b/configure
-@@ -3623,27 +3623,20 @@ echo $ECHO_N "checking if we should inst
-       # Leave this as something that can be overridden in the environment.
-       if test -z "$PKG_CONFIG_LIBDIR" ; then
--              PKG_CONFIG_LIBDIR=`echo "$PKG_CONFIG" | sed -e 's,/[^/]*/[^/]*$,,'`/lib/pkgconfig
-+              PKG_CONFIG_LIBDIR="/usr/lib/pkgconfig"
-       fi
-+
-       PKG_CONFIG_LIBDIR=`echo "$PKG_CONFIG_LIBDIR" | sed -e 's/^://' -e 's/:.*//'`
--      if test -n "$PKG_CONFIG_LIBDIR" && test -d "$PKG_CONFIG_LIBDIR" ; then
--# Check whether --enable-pc-files or --disable-pc-files was given.
--if test "${enable_pc_files+set}" = set; then
--  enableval="$enable_pc_files"
--  enable_pc_files=$enableval
--else
--  enable_pc_files=no
--fi;
--              echo "$as_me:3638: result: $enable_pc_files" >&5
--echo "${ECHO_T}$enable_pc_files" >&6
-+        # Check whether --enable-pc-files or --disable-pc-files was given.
-+      if test "${enable_pc_files+set}" = set; then
-+          enableval="$enable_pc_files"
-+          enable_pc_files=$enableval
-       else
--              echo "$as_me:3641: result: no" >&5
--echo "${ECHO_T}no" >&6
--              { echo "$as_me:3643: WARNING: did not find library $PKG_CONFIG_LIBDIR" >&5
--echo "$as_me: WARNING: did not find library $PKG_CONFIG_LIBDIR" >&2;}
--              enable_pc_files=no
--      fi
-+          enable_pc_files=no
-+      fi;
-+      echo "$as_me:3638: result: $enable_pc_files" >&5
-+      echo "${ECHO_T}$enable_pc_files" >&6
- fi
- echo "$as_me:3649: checking if we should assume mixed-case filenames" >&5
---- a/configure.in
-+++ b/configure.in
-@@ -174,20 +174,14 @@ if test "$PKG_CONFIG" != no ; then
-       # Leave this as something that can be overridden in the environment.
-       if test -z "$PKG_CONFIG_LIBDIR" ; then
--              PKG_CONFIG_LIBDIR=`echo "$PKG_CONFIG" | sed -e 's,/[[^/]]*/[[^/]]*$,,'`/lib/pkgconfig
-+              PKG_CONFIG_LIBDIR="/usr/lib/pkgconfig"
-       fi
-       PKG_CONFIG_LIBDIR=`echo "$PKG_CONFIG_LIBDIR" | sed -e 's/^://' -e 's/:.*//'`
--      if test -n "$PKG_CONFIG_LIBDIR" && test -d "$PKG_CONFIG_LIBDIR" ; then
--              AC_ARG_ENABLE(pc-files,
-+      AC_ARG_ENABLE(pc-files,
-                       [  --enable-pc-files       generate and install .pc files for pkg-config],
-                       [enable_pc_files=$enableval],
-                       [enable_pc_files=no])
--              AC_MSG_RESULT($enable_pc_files)
--      else
--              AC_MSG_RESULT(no)
--              AC_MSG_WARN(did not find library $PKG_CONFIG_LIBDIR)
--              enable_pc_files=no
--      fi
-+      AC_MSG_RESULT($enable_pc_files)
- fi
- AC_SUBST(PKG_CONFIG_LIBDIR)
index 976a3cba2a177869001bed0d4cdbb9951473d846..590bddf68ced4485aaf9f2ae92373baf7513b0fd 100644 (file)
@@ -1,11 +1,11 @@
 --- a/aclocal.m4
 +++ b/aclocal.m4
-@@ -5137,7 +5137,7 @@ CF_EOF
-                       EXTRA_LDFLAGS="${cf_ld_rpath_opt}\${libdir} $EXTRA_LDFLAGS"
+@@ -5720,7 +5720,7 @@ CF_EOF
+                       EXTRA_LDFLAGS="${cf_ld_rpath_opt}\${RPATH_LIST} $EXTRA_LDFLAGS"
                fi
                CF_SHARED_SONAME
 -              MK_SHARED_LIB='${CC} ${CFLAGS} -shared -Wl,-soname,'$cf_cv_shared_soname',-stats,-lc -o $[@]'
 +              MK_SHARED_LIB='${CC} ${CFLAGS} -shared -Wl,-soname,'$cf_shared_soname',-stats,$(LDFLAGS) -lc -o $[@]'
                ;;
-       openbsd[[2-9]].*) #(vi
-               if test "$DFT_LWR_MODEL" = "shared" ; then
+       (mingw*)
+               cf_cv_shlib_version=mingw
index 487a341ba9ef8a27018a1f441ba34649bd44090a..ab623b1973ce9f621a8c8fe0be73f24d70d5ee55 100644 (file)
@@ -1,6 +1,6 @@
 --- a/misc/terminfo.src
 +++ b/misc/terminfo.src
-@@ -3947,12 +3947,11 @@ konsole-xf3x|KDE console window with key
+@@ -4919,12 +4919,11 @@ konsole-xf3x|KDE console window with key
  # The value for kbs reflects local customization rather than the settings used
  # for XFree86 xterm.
  konsole-xf4x|KDE console window with keyboard for XFree86 4.x xterm,