kernel: bump 4.19 to 4.19.57
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 9 Jul 2019 10:43:23 +0000 (12:43 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 9 Jul 2019 15:03:18 +0000 (17:03 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.19/901-debloat_sock_diag.patch
target/linux/generic/hack-4.19/902-debloat_proc.patch
target/linux/generic/pending-4.19/630-packet_socket_type.patch

index ec3ebd130cc09b256299278c32902f8775771ccb..17ef3aff0d5173a830e39aa14c5e9d2ebe7aa125 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .184
 LINUX_VERSION-4.14 = .132
-LINUX_VERSION-4.19 = .56
+LINUX_VERSION-4.19 = .57
 
 LINUX_KERNEL_HASH-4.9.184 = 033114d5350525dede995d31b596c31b0e26db8d77a0a1c53d36cdc36ead9faf
 LINUX_KERNEL_HASH-4.14.132 = da86f39a722da656fce4e2685223093b5d5f4db94046fcd79e492428a82ff330
-LINUX_KERNEL_HASH-4.19.56 = 7326943215b9496f302e95892457a63d9a77e0446e99dd7bade6b425bc966bdf
+LINUX_KERNEL_HASH-4.19.57 = 327c5759d5888361d6c9d6adb0c8ad7e3c624eb05bb9e5869d9f3078dd0d3f87
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 33c8b7231779472e58cb33a92e5647321fd5921b..9f7ead6b1182b35891a25e51098b20ee10b108e8 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  struct dst_entry *__sk_dst_check(struct sock *sk, u32 cookie)
  {
        struct dst_entry *dst = __sk_dst_get(sk);
-@@ -1601,9 +1613,11 @@ static void __sk_free(struct sock *sk)
+@@ -1598,9 +1610,11 @@ static void __sk_free(struct sock *sk)
        if (likely(sk->sk_net_refcnt))
                sock_inuse_add(sock_net(sk), -1);
  
index ef272f171ce66fa40eba474a8cff88a04ccf0d40..77de3c67e9ad7ad4fef1cbf8d92940e813f6c625 100644 (file)
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3483,6 +3483,8 @@ static __net_initdata struct pernet_oper
+@@ -3480,6 +3480,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index 333d4f5739e6e9aa967aac6539be74d9c6a411b1..1e4b075e8d8a1648d1bb993f6303ddfc82a43a9e 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3237,6 +3239,7 @@ static int packet_create(struct net *net
+@@ -3251,6 +3253,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3848,6 +3851,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3862,6 +3865,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3900,6 +3913,13 @@ static int packet_getsockopt(struct sock
+@@ -3914,6 +3927,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
@@ -128,7 +128,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                break;
 --- a/net/packet/internal.h
 +++ b/net/packet/internal.h
-@@ -131,6 +131,7 @@ struct packet_sock {
+@@ -132,6 +132,7 @@ struct packet_sock {
        struct net_device __rcu *cached_dev;
        int                     (*xmit)(struct sk_buff *skb);
        struct packet_type      prot_hook ____cacheline_aligned_in_smp;