ipq40xx: only include ath10k-board-qca4019 for the generic subtarget
[openwrt/staging/chunkeey.git] / toolchain / gdb / Makefile
index fa5179a5dc524ec11f8ad791f948a99f019b3f95..6ed3b190ce584e6b099a4857e38da03cd1689ae8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2020 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,17 +7,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=7.8
+PKG_VERSION:=11.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_MD5SUM:=bd958fe9019d7c7896f29f6724a764ed
+PKG_HASH:=1497c36a71881b8671a9a84a0ee40faab788ca30d7ba19d8463c3cc787152e32
+GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
 HOST_CONFIGURE_VARS += \
+       acx_cv_cc_gcc_supports_ada=false \
        gdb_cv_func_sigsetjmp=yes
 
 HOST_CONFIGURE_ARGS = \
@@ -25,18 +30,37 @@ HOST_CONFIGURE_ARGS = \
        --build=$(GNU_HOST_NAME) \
        --host=$(GNU_HOST_NAME) \
        --target=$(REAL_GNU_TARGET_NAME) \
+       --with-gmp=$(TOPDIR)/staging_dir/host \
+       --with-mpfr=$(TOPDIR)/staging_dir/host \
+       --with-mpc=$(TOPDIR)/staging_dir/host \
        --disable-werror \
        --without-uiout \
-       --disable-tui --disable-gdbtk --without-x \
+       --enable-tui --disable-gdbtk --without-x \
        --without-included-gettext \
        --enable-threads \
-       --with-expat
+       --with-expat \
+       --disable-unit-tests \
+       --disable-ubsan \
+       --disable-binutils \
+       --disable-ld \
+       --disable-gas \
+       --disable-sim
+
+ifneq ($(CONFIG_GDB_PYTHON),)
+  HOST_CONFIGURE_ARGS+= --with-python
+else
+  HOST_CONFIGURE_ARGS+= --without-python
+endif
 
 define Host/Install
        mkdir -p $(TOOLCHAIN_DIR)/bin
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/gdb $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
        ln -fs $(TARGET_CROSS)gdb $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-gdb
        strip $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
+       mkdir -p $(TOOLCHAIN_DIR)/share/gdb
+       -cp -R $(HOST_BUILD_DIR)/gdb/data-directory/python $(TOOLCHAIN_DIR)/share/gdb/
+       cp -R $(HOST_BUILD_DIR)/gdb/data-directory/syscalls $(TOOLCHAIN_DIR)/share/gdb/
+       cp -R $(HOST_BUILD_DIR)/gdb/data-directory/system-gdbinit $(TOOLCHAIN_DIR)/share/gdb/
 endef
 
 define Host/Clean