ipq40xx: only include ath10k-board-qca4019 for the generic subtarget
[openwrt/staging/chunkeey.git] / tools / xz / Makefile
index 8156c92c7c74d577eb2aa2bb5328b29951a66ec6..4b13f727da4db65336211f3ce66dc24e8f3f2afe 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2013 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,21 +7,30 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xz
-PKG_VERSION:=5.0.5
+PKG_VERSION:=5.2.5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://tukaani.org/xz
-PKG_MD5SUM:=db44efe0d53ac4317627624b98c63da0
+PKG_SOURCE_URL:=@SF/lzmautils \
+               http://tukaani.org/xz
+PKG_HASH:=5117f930900b341493827d63aa910ff5e011e0b994197c3b71c08a20228a42df
+PKG_CPE_ID:=cpe:/a:tukaani:xz
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
+HOST_CONFIGURE_ARGS += \
+       --enable-static=yes \
+       --enable-shared=no \
+       --disable-doc \
+       --disable-nls \
+       --with-pic
 
 define Host/Install
-       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
-               AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
 
 $(eval $(call HostBuild))