kernel: bump 4.14 to 4.14.132
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 9 Jul 2019 10:18:49 +0000 (12:18 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 9 Jul 2019 15:03:10 +0000 (17:03 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/hack-4.14/901-debloat_sock_diag.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/630-packet_socket_type.patch

index 872ee475fe4d81f61280e1802809d50f809a08c8..ec3ebd130cc09b256299278c32902f8775771ccb 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .184
-LINUX_VERSION-4.14 = .131
+LINUX_VERSION-4.14 = .132
 LINUX_VERSION-4.19 = .56
 
 LINUX_KERNEL_HASH-4.9.184 = 033114d5350525dede995d31b596c31b0e26db8d77a0a1c53d36cdc36ead9faf
-LINUX_KERNEL_HASH-4.14.131 = 19f6404c30f4a9a1fe3315b902676b6d63a470be5d55cf2a0e47983c643c8ff5
+LINUX_KERNEL_HASH-4.14.132 = da86f39a722da656fce4e2685223093b5d5f4db94046fcd79e492428a82ff330
 LINUX_KERNEL_HASH-4.19.56 = 7326943215b9496f302e95892457a63d9a77e0446e99dd7bade6b425bc966bdf
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 86d101be260929a2698689ef4e65f4b09a77702a..fd90ad743fcb6277f98ccfbb1f4cf2c3067af668 100644 (file)
@@ -55,7 +55,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
        rwlock_t                sk_callback_lock;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2743,6 +2743,7 @@ void sock_init_data(struct socket *sock,
+@@ -2740,6 +2740,7 @@ void sock_init_data(struct socket *sock,
  
        sk->sk_max_pacing_rate = ~0U;
        sk->sk_pacing_rate = ~0U;
index 36d69c1dfde9e1d703369e2ff5f690de29f719eb..118b1a79c693d403971ff3f5c759151415a0a545 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  struct dst_entry *__sk_dst_check(struct sock *sk, u32 cookie)
  {
        struct dst_entry *dst = __sk_dst_get(sk);
-@@ -1596,9 +1608,11 @@ void sk_destruct(struct sock *sk)
+@@ -1593,9 +1605,11 @@ void sk_destruct(struct sock *sk)
  
  static void __sk_free(struct sock *sk)
  {
index 8e7d6ac9ff885c5d261d0f0ca577afc1ff928b65..12809bb1beeca2217308384c1635232a484c2a47 100644 (file)
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3382,6 +3382,8 @@ static __net_initdata struct pernet_oper
+@@ -3379,6 +3379,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index 0b9addc36eef800b78fa763530fc9d0d891405b4..57b076c559484acd07652db56e72326663eec24b 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3273,6 +3275,7 @@ static int packet_create(struct net *net
+@@ -3287,6 +3289,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3886,6 +3889,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3900,6 +3903,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3938,6 +3951,13 @@ static int packet_getsockopt(struct sock
+@@ -3952,6 +3965,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
@@ -128,7 +128,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                break;
 --- a/net/packet/internal.h
 +++ b/net/packet/internal.h
-@@ -131,6 +131,7 @@ struct packet_sock {
+@@ -132,6 +132,7 @@ struct packet_sock {
        struct net_device __rcu *cached_dev;
        int                     (*xmit)(struct sk_buff *skb);
        struct packet_type      prot_hook ____cacheline_aligned_in_smp;