clean up reject files after copying target/linux/*/files to the kernel tree
authorFelix Fietkau <nbd@openwrt.org>
Thu, 3 Apr 2008 18:37:30 +0000 (18:37 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 3 Apr 2008 18:37:30 +0000 (18:37 +0000)
SVN-Revision: 10722

include/quilt.mk

index f07f4c5249524b94c0176dd75ed0c774f2562a47..95f81e7094f6ac1f025bb6cf52ef0b9b0973856e 100644 (file)
@@ -68,7 +68,10 @@ endef
 define Kernel/Patch/Default
        $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
        if [ -d $(GENERIC_PLATFORM_DIR)/files ]; then $(CP) $(GENERIC_PLATFORM_DIR)/files/* $(LINUX_DIR)/; fi
-       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+       if [ -d ./files ]; then \
+               $(CP) ./files/* $(LINUX_DIR)/; \
+               find $(LINUX_DIR)/ -name \*.rej | xargs rm -f; \
+       fi
        $(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
        $(call PatchDir,$(PATCH_DIR),platform/)
 endef