base-files: change boot & umount STOP indexes
authorJoseph Tingiris <joseph.tingiris@gmail.com>
Sun, 13 Jan 2019 21:43:48 +0000 (16:43 -0500)
committerChristian Lamparter <chunkeey@gmail.com>
Mon, 24 Jun 2019 18:22:23 +0000 (20:22 +0200)
This patch is in a series to allow additional STOP indexes after umount,
so that other block devices may stop cleanly.

boot is now STOP=90
umount is now STOP=90

After this patch series, the resulting STOP indexes in the 80s & 90s
will be:

STOP=85 odhcpd.init
STOP=89 conntrackd.init
STOP=89 log.init
STOP=89 rssileds.init
STOP=90 boot
STOP=90 kdump.init
STOP=90 network
STOP=90 sysfixtime
STOP=90 umount
STOP=98 mdadm.init (note: will be addressed in a separate patch)

Signed-off-by: Joseph Tingiris <joseph.tingiris@gmail.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
[PKG_RELEASE is now 200]

package/base-files/Makefile
package/base-files/files/etc/init.d/boot
package/base-files/files/etc/init.d/umount

index a6dee5aa5a8aec1c072812fd5ed36107478080bd..7129d488dbee9d45c697dc24c3bcc7f98214eead 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=199
+PKG_RELEASE:=200
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 31f245ffc759b10ecda46d87ca70a26bab8b5a2a..09b7f44c794a11ff6e49796454483754cca5ac4b 100755 (executable)
@@ -2,7 +2,7 @@
 # Copyright (C) 2006-2011 OpenWrt.org
 
 START=10
-STOP=98
+STOP=90
 
 uci_apply_defaults() {
        . /lib/functions/system.sh
index 349b2b32648e6d92595bce2f3600ea121ad9c8cc..57a4a6d90c3707c06ac5fa5ea26a783dd0a60d82 100755 (executable)
@@ -1,7 +1,7 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006 OpenWrt.org
 
-STOP=99
+STOP=90
 stop() {
        sync
        /bin/umount -a -d -r