toolchain: disable libatomic for gcc 4.6
authorFelix Fietkau <nbd@openwrt.org>
Thu, 11 Dec 2014 17:52:22 +0000 (17:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 11 Dec 2014 17:52:22 +0000 (17:52 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43623

package/libs/toolchain/Makefile

index 10c990a12634dd3dc062544baa7521be7811355e..9a2bf5264a5540e0b31d7d9d2bddcc589e81c405 100644 (file)
@@ -402,7 +402,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 
   define Package/libatomic/install
        $(INSTALL_DIR) $(1)/lib
-       $(if $(CONFIG_TARGET_avr32)$(CONFIG_TARGET_coldfire),,$(CP) $(TOOLCHAIN_DIR)/lib/libatomic.so.* $(1)/lib/)
+       $(if $(CONFIG_GCC_VERSION_4_6)$(CONFIG_TARGET_avr32)$(CONFIG_TARGET_coldfire),,$(CP) $(TOOLCHAIN_DIR)/lib/libatomic.so.* $(1)/lib/)
   endef
 
   define Package/libgfortran/install