kernel: split kernel version to dedicated files
authorAnsuel Smith <ansuelsmth@gmail.com>
Mon, 10 Jan 2022 16:02:30 +0000 (17:02 +0100)
committerRui Salvaterra <rsalvaterra@gmail.com>
Thu, 13 Jan 2022 23:46:39 +0000 (23:46 +0000)
Move the kernel versions and hash to dedicated files.
This makes kernel bump quicker and fix some annoying
problem with rebasing when multiple kernel bump are proposed.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
[Rebased on top of current master]
Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
include/kernel-5.10 [new file with mode: 0644]
include/kernel-5.4 [new file with mode: 0644]
include/kernel-version.mk

diff --git a/include/kernel-5.10 b/include/kernel-5.10
new file mode 100644 (file)
index 0000000..e816698
--- /dev/null
@@ -0,0 +1,2 @@
+LINUX_VERSION-5.10 = .90
+LINUX_KERNEL_HASH-5.10.90 = 945e4264c014a3d9dfc0a4639309dd1ec2fb545416556421f931b95da78c2725
diff --git a/include/kernel-5.4 b/include/kernel-5.4
new file mode 100644 (file)
index 0000000..e85b7ad
--- /dev/null
@@ -0,0 +1,2 @@
+LINUX_VERSION-5.4 = .170
+LINUX_KERNEL_HASH-5.4.170 = b09f74e0cf5fc7cf5de6aa932fe654c962cb10118bdbbdddb397022c6e6d382c
index 677693ad085be656018990480a946561ad121b95..1edb01df278571cdcfc527d461fc0976f55cf682 100644 (file)
@@ -6,11 +6,12 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .170
-LINUX_VERSION-5.10 = .90
+KERNEL_DETAILS_FILE=$(INCLUDE_DIR)/kernel-$(KERNEL_PATCHVER)
+ifeq ($(wildcard $(KERNEL_DETAILS_FILE)),)
+  $(error Missing kernel version/hash file for $(KERNEL_PATCHVER). Please create $(KERNEL_DETAILS_FILE))
+endif
 
-LINUX_KERNEL_HASH-5.4.170 = b09f74e0cf5fc7cf5de6aa932fe654c962cb10118bdbbdddb397022c6e6d382c
-LINUX_KERNEL_HASH-5.10.90 = 945e4264c014a3d9dfc0a4639309dd1ec2fb545416556421f931b95da78c2725
+include $(KERNEL_DETAILS_FILE)
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))