ppp: make ppp-multilink provide ppp
authorFelix Fietkau <nbd@nbd.name>
Thu, 8 Mar 2018 10:14:09 +0000 (11:14 +0100)
committerFelix Fietkau <nbd@nbd.name>
Mon, 12 Mar 2018 19:02:29 +0000 (20:02 +0100)
Fixes dependencies on ppp from other packages

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/network/services/ppp/Makefile

index beeaa53c220c76ce9d875cd0ff2700186ab9654c..ab8780b83d589f04e99c3cf5ccb65dbcf3714469 100644 (file)
@@ -46,6 +46,7 @@ $(call Package/ppp/Default)
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon (with multilink support)
   VARIANT:=multilink
+  PROVIDES:=ppp
 endef
 
 define Package/ppp/description
@@ -64,7 +65,7 @@ endef
 
 define Package/ppp-mod-pppoa
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +linux-atm +kmod-pppoa
+  DEPENDS:=ppp +linux-atm +kmod-pppoa
   TITLE:=PPPoA plugin
 endef
 
@@ -74,7 +75,7 @@ endef
 
 define Package/ppp-mod-pppoe
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pppoe
+  DEPENDS:=ppp +kmod-pppoe
   TITLE:=PPPoE plugin
 endef
 
@@ -84,7 +85,7 @@ endef
 
 define Package/ppp-mod-radius
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
+  DEPENDS:=ppp
   TITLE:=RADIUS plugin
 endef
 
@@ -100,7 +101,7 @@ endef
 
 define Package/ppp-mod-pppol2tp
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pppol2tp
+  DEPENDS:=ppp +kmod-pppol2tp
   TITLE:=PPPoL2TP plugin
 endef
 
@@ -110,7 +111,7 @@ endef
 
 define Package/ppp-mod-pptp
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +kmod-pptp +kmod-mppe +resolveip
+  DEPENDS:=ppp +kmod-pptp +kmod-mppe +resolveip
   TITLE:=PPtP plugin
 endef
 
@@ -120,7 +121,7 @@ endef
 
 define Package/ppp-mod-passwordfd
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
+  DEPENDS:=ppp
   TITLE:=pap/chap secret from filedescriptor
 endef
 
@@ -141,7 +142,7 @@ endef
 
 define Package/pppdump
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
+  DEPENDS:=ppp
   TITLE:=Read PPP record file
 endef
 
@@ -151,7 +152,7 @@ endef
 
 define Package/pppstats
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink)
+  DEPENDS:=ppp
   TITLE:=Report PPP statistics
 endef
 
@@ -161,7 +162,7 @@ endef
 
 define Package/pppoe-discovery
 $(call Package/ppp/Default)
-  DEPENDS:=@(PACKAGE_ppp||PACKAGE_ppp-multilink) +ppp-mod-pppoe
+  DEPENDS:=ppp +ppp-mod-pppoe
   TITLE:=Perform a PPPoE-discovery process
 endef