kernel: remove kmod-acpi-button package, it is already built into the kernel
authorFelix Fietkau <nbd@openwrt.org>
Sat, 7 Nov 2015 16:22:23 +0000 (16:22 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 7 Nov 2015 16:22:23 +0000 (16:22 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47414

package/kernel/linux/modules/input.mk

index 0539493cbd1655e52a019b6269ed56bc3cfd6160..539d2707aa61cb81cf0a8e69d02b344e1a20d87c 100644 (file)
@@ -173,22 +173,6 @@ endef
 $(eval $(call KernelPackage,input-matrixkmap))
 
 
 $(eval $(call KernelPackage,input-matrixkmap))
 
 
-define KernelPackage/acpi-button
-  SUBMENU:=$(INPUT_MODULES_MENU)
-  TITLE:=ACPI Button Support
-  DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu||TARGET_x86_64) +kmod-input-evdev
-  KCONFIG:=CONFIG_ACPI_BUTTON
-  FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
-  AUTOLOAD:=$(call AutoLoad,06,button)
-endef
-
-define KernelPackage/acpi-button/description
- Kernel module for ACPI Button support
-endef
-
-$(eval $(call KernelPackage,acpi-button))
-
-
 define KernelPackage/keyboard-imx
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=IMX keypad support
 define KernelPackage/keyboard-imx
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=IMX keypad support