build: fix libressl build on x32 (amd64ilp32) host
authorThorsten Glaser <tg@mirbsd.org>
Mon, 22 Oct 2018 19:00:57 +0000 (21:00 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:22:03 +0000 (17:22 +0100)
disable use of assembly code since x32 gets misdetected as amd64

Signed-off-by: Thorsten Glaser <tg@mirbsd.org>
(backported from a395563f68fde6f52dbf10913f59f13b8c804cd5)

tools/libressl/Makefile

index 4c7e8a7b6ecc1c57cd004869a3d4dd3b3ad29328..bb8113a4ada492e9577a36a87307d52ab1966ef8 100644 (file)
@@ -24,4 +24,8 @@ include $(INCLUDE_DIR)/host-build.mk
 HOST_CONFIGURE_ARGS += --disable-shared
 HOST_CFLAGS += $(FPIC)
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += --disable-asm
+endif
+
 $(eval $(call HostBuild))