cns3xxx: build images for the old boot loader and the new one (default to the new...
authorFelix Fietkau <nbd@openwrt.org>
Wed, 19 Sep 2012 23:50:09 +0000 (23:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 19 Sep 2012 23:50:09 +0000 (23:50 +0000)
SVN-Revision: 33488

target/linux/cns3xxx/image/Makefile

index 0265d7c54503a52f2b775363764070d7dd82f28f..271d5ea1988938cf7e22bcda8071d0d5e08fc331 100644 (file)
@@ -7,12 +7,18 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+define mkimage
+       mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage-$(1)
+endef
+
 define Image/Prepare
-       cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+       $(call mkimage,old,0x00008000)
+       $(call mkimage,new,0x20008000)
 endef
 
 define Image/BuildKernel
-       cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+       cp $(KDIR)/uImage-old $(BIN_DIR)/openwrt-$(BOARD)-old-uboot-uImage
+       cp $(KDIR)/uImage-new $(BIN_DIR)/openwrt-$(BOARD)-uImage
 endef
 
 define Image/Build