ath79: add support for the TP-LINK CPE220 V3
authorAndrew Cameron <apcameron@softhome.net>
Sat, 26 Oct 2019 01:29:36 +0000 (20:29 -0500)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 8 Jan 2020 16:42:37 +0000 (17:42 +0100)
This adds support for a popular low-cost 2.4GHz N based AP

Specifications:
SoC: Qualcomm Atheros QCA9533 (650MHz)
RAM: 64MB
Storage: 8 MB SPI NOR
Wireless: 2.4GHz N based built into SoC 2x2
Ethernet: 2x 100/10 Mbps, integrated into SoC

Installation:
Flash factory image through stock firmware WEB UI
or through TFTP
To get to TFTP recovery just hold reset button while powering on for
around 4-5 seconds and release.
Rename factory image to recovery.bin
Stock TFTP server IP:192.168.0.100
Stock device TFTP adress:192.168.0.254

This also applies some minor changes to the common DTSI:
- use &wmac for label-mac-device, as this one is actually set up in
  common DTSI
- move &eth0 to parent DTSI
- fix several leading spaces, added/removed newlines

Signed-off-by: Andrew Cameron <apcameron@softhome.net>
[DTS style fixes/improvements, updated commit message/title,
backport to 19.07]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/board.d/03_gpio_switches
target/linux/ath79/dts/qca9533_tplink_cpe210.dtsi
target/linux/ath79/dts/qca9533_tplink_cpe220-v3.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9533_tplink_cpexxx.dtsi [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index ea45ce60324bb83550505bd6a0b1e1cbb77ca678..be5d29d97c365ca053dccd16f1580e5edbfdff5d 100755 (executable)
@@ -148,6 +148,15 @@ tplink,archer-d50-v1)
        ucidef_set_led_switch "wan_data" "WAN Data" "tp-link:white:internet" "switch0" "0x02" "" "tx rx"
        ucidef_set_led_switch "wan_link" "WAN Link" "tp-link:white:wan" "switch0" "0x02" "" "link"
        ;;
+tplink,cpe220-v3)
+       ucidef_set_led_netdev "lan0" "LAN0" "tp-link:green:lan0" "eth1"
+       ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
+       ucidef_set_rssimon "wlan0" "200000" "1"
+       ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:green:link1" "wlan0" "1" "100"
+       ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:green:link2" "wlan0" "30" "100"
+       ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "tp-link:green:link3" "wlan0" "60" "100"
+       ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "tp-link:green:link4" "wlan0" "80" "100"
+       ;;
 tplink,cpe210-v2|\
 tplink,cpe210-v3)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
index 8f2951b9f2acef923dff3404db911c361d073ecb..b342c8b5e42a67a6f34911618c247b10d51438c2 100755 (executable)
@@ -89,6 +89,7 @@ ath79_setup_interfaces()
                ;;
        comfast,cf-e110n-v2|\
        comfast,cf-e120a-v3|\
+       tplink,cpe220-v3|\
        ubnt,nanostation-m|\
        ubnt,routerstation)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
index 8a3312389cb3512968be502f112690502dd2ec66..e2fe3b350b64def930e1569e34636ae31c50d907 100755 (executable)
@@ -27,6 +27,9 @@ tplink,archer-c25-v1)
        ucidef_add_gpio_switch "led_control" "LED control" "21" "0"
        ucidef_add_gpio_switch "led_reset" "LED reset" "19" "1"
        ;;
+tplink,cpe220-v3)
+       ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "20"
+       ;;
 ubnt,nanostation-ac)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "3"
        ;;
index f86ff30fc7b09d99b55a07dcf0b08f0c9640278a..cb329a9a667feee21a4e6026aaca3c2f7c8a6703 100644 (file)
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 /dts-v1/;
 
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "qca9533_tplink_cpexxx.dtsi"
 
-#include "qca953x.dtsi"
-
-/ {
-       chosen {
-               bootargs = "console=ttyS0,115200n8";
-       };
-
-       aliases {
-               led-boot = &system;
-               led-failsafe = &system;
-               led-running = &system;
-               led-upgrade = &system;
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               lan {
-                       label = "tp-link:green:lan";
-                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
-               };
-
-               link1 {
-                       label = "tp-link:green:link1";
-                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
-               };
-
-               link2 {
-                       label = "tp-link:green:link2";
-                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
-               };
-
-               link3 {
-                       label = "tp-link:green:link3";
-                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
-               };
-
-               system: link4 {
-                       label = "tp-link:green:link4";
-                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               poll-interval = <100>;
-
-               reset_button {
-                       label = "Reset button";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&uart {
-       status = "okay";
-};
-
-&spi {
-       status = "okay";
-       num-cs = <1>;
-
-       flash@0 {
-               #address-cells = <1>;
-               #size-cells = <1>;
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       uboot: partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x020000>;
-                               read-only;
-                       };
-
-                       partition@20000 {
-                               label = "partition-table";
-                               reg = <0x020000 0x10000>;
-                               read-only;
-                       };
-
-                       info: partition@30000 {
-                               label = "info";
-                               reg = <0x030000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@40000 {
-                               label = "firmware";
-                               reg = <0x040000 0x780000>;
-                               compatible = "tplink,firmware";
-                       };
-
-                       config: partition@7c0000 {
-                               label = "config";
-                               reg = <0x7c0000 0x30000>;
-                               read-only;
-                       };
-
-                       art: partition@7f0000 {
-                               label = "art";
-                               reg = <0x7f0000 0x10000>;
-                               read-only;
-                       };
-               };
+&leds {
+       lan {
+               label = "tp-link:green:lan";
+               gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
        };
 };
 
-&eth0 {
-       status = "okay";
-       phy-handle = <&swphy4>;
-       mtd-mac-address = <&info 0x8>;
-};
-
 &eth1 {
        compatible = "syscon", "simple-mfd";
 };
-
-&wmac {
-       status = "okay";
-       mtd-cal-data = <&art 0x1000>;
-       mtd-mac-address = <&info 0x8>;
-};
diff --git a/target/linux/ath79/dts/qca9533_tplink_cpe220-v3.dts b/target/linux/ath79/dts/qca9533_tplink_cpe220-v3.dts
new file mode 100644 (file)
index 0000000..dd90eb1
--- /dev/null
@@ -0,0 +1,33 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_cpexxx.dtsi"
+
+/ {
+       compatible = "tplink,cpe220-v3", "qca,qca9533";
+       model = "TP-Link CPE220 v3";
+};
+
+&leds {
+       lan0 {
+               label = "tp-link:green:lan0";
+               gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+       };
+
+       lan1 {
+               label = "tp-link:green:lan1";
+               gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+       };
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&info 0x8>;
+
+       gmac-config {
+               device = <&gmac>;
+               switch-phy-swap = <0>;
+               switch-only-mode = <1>;
+       };
+};
diff --git a/target/linux/ath79/dts/qca9533_tplink_cpexxx.dtsi b/target/linux/ath79/dts/qca9533_tplink_cpexxx.dtsi
new file mode 100644 (file)
index 0000000..ae9cb24
--- /dev/null
@@ -0,0 +1,130 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &led_link4;
+               led-failsafe = &led_link4;
+               led-running = &led_link4;
+               led-upgrade = &led_link4;
+       };
+
+       leds: leds {
+               compatible = "gpio-leds";
+
+               link1 {
+                       label = "tp-link:green:link1";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               link2 {
+                       label = "tp-link:green:link2";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               link3 {
+                       label = "tp-link:green:link3";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               led_link4: link4 {
+                       label = "tp-link:green:link4";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <100>;
+
+               reset_button {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "partition-table";
+                               reg = <0x020000 0x010000>;
+                               read-only;
+                       };
+
+                       info: partition@30000 {
+                               label = "info";
+                               reg = <0x030000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "firmware";
+                               reg = <0x040000 0x780000>;
+                               compatible = "tplink,firmware";
+                       };
+
+                       config: partition@7c0000 {
+                               label = "config";
+                               reg = <0x7c0000 0x030000>;
+                               read-only;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&info 0x8>;
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+
+       mtd-mac-address = <&info 0x8>;
+};
index 304304799d8eaff91f142ee7c60ac4064c4e5d47..9b1b272a7e425324579702b5693b830830779bb4 100644 (file)
@@ -168,6 +168,17 @@ define Device/tplink_cpe210-v3
 endef
 TARGET_DEVICES += tplink_cpe210-v3
 
+define Device/tplink_cpe220-v3
+  $(Device/tplink-safeloader)
+  ATH_SOC := qca9533
+  IMAGE_SIZE := 7680k
+  DEVICE_TITLE := TP-Link CPE220 v3
+  DEVICE_PACKAGES := rssileds
+  TPLINK_BOARD_ID := CPE220V3
+  LOADER_TYPE := elf
+endef
+TARGET_DEVICES += tplink_cpe220-v3
+
 define Device/tplink_archer-d50-v1
   ATH_SOC := qca9531
   DEVICE_TITLE := TP-Link Archer D50 v1
index a53b05c478550e835e5cd7b68ade87ad913ce9c5..62bbac0c0ed43c22da865140eaa6f2d87c347341 100644 (file)
@@ -231,6 +231,47 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "support-list",
        },
 
+       /** Firmware layout for the CPE220 V3 */
+       {
+               .id     = "CPE220V3",
+               .vendor = "CPE220(TP-LINK|UN|N300-2|00000000):3.0\r\n",
+               .support_list =
+                       "SupportList:\r\n"
+                       "CPE220(TP-LINK|EU|N300-2|00000000):3.0\r\n"
+                       "CPE220(TP-LINK|EU|N300-2|45550000):3.0\r\n"
+                       "CPE220(TP-LINK|EU|N300-2|55530000):3.0\r\n"
+                       "CPE220(TP-LINK|UN|N300-2|00000000):3.0\r\n"
+                       "CPE220(TP-LINK|UN|N300-2|45550000):3.0\r\n"
+                       "CPE220(TP-LINK|UN|N300-2|55530000):3.0\r\n"
+                       "CPE220(TP-LINK|US|N300-2|55530000):3.0\r\n"
+                       "CPE220(TP-LINK|UN|N300-2):3.0\r\n"
+                       "CPE220(TP-LINK|EU|N300-2):3.0\r\n"
+                       "CPE220(TP-LINK|US|N300-2):3.0\r\n",
+               .support_trail = '\xff',
+               .soft_ver = NULL,
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x20000},
+                       {"partition-table", 0x20000, 0x02000},
+                       {"default-mac", 0x30000, 0x00020},
+                       {"product-info", 0x31100, 0x00100},
+                       {"device-info", 0x31400, 0x00400},
+                       {"signature", 0x32000, 0x00400},
+                       {"device-id", 0x33000, 0x00100},
+                       {"firmware", 0x40000, 0x770000},
+                       {"soft-version", 0x7b0000, 0x00100},
+                       {"support-list", 0x7b1000, 0x01000},
+                       {"user-config", 0x7c0000, 0x10000},
+                       {"default-config", 0x7d0000, 0x10000},
+                       {"log", 0x7e0000, 0x10000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "support-list",
+       },
+
        /** Firmware layout for the CPE510/520 V1 */
        {
                .id     = "CPE510",