ath79: move Netgear build code into a common makefile
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 13 Jun 2018 08:51:51 +0000 (10:51 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 18 Jun 2018 05:10:19 +0000 (07:10 +0200)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/ath79/image/common-netgear.mk [new file with mode: 0644]
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/image/common-netgear.mk b/target/linux/ath79/image/common-netgear.mk
new file mode 100644 (file)
index 0000000..ca4e005
--- /dev/null
@@ -0,0 +1,22 @@
+define Build/netgear-squashfs
+       rm -rf $@.fs $@.squashfs
+       mkdir -p $@.fs/image
+       cp $@ $@.fs/image/uImage
+       $(STAGING_DIR_HOST)/bin/mksquashfs-lzma  \
+               $@.fs $@.squashfs -be \
+               -noappend -root-owned -b 65536 \
+               $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+
+       dd if=/dev/zero bs=1k count=1 >> $@.squashfs
+       mkimage \
+               -A mips -O linux -T filesystem -C none \
+               -M $(NETGEAR_KERNEL_MAGIC) \
+               -a 0xbf070000 -e 0xbf070000 \
+               -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
+               -d $@.squashfs $@
+       rm -rf $@.squashfs $@.fs
+endef
+
+define Build/netgear-uImage
+       $(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
+endef
index 9475d0ab332f8fe1b1929aea14ec9791939643b5..6e662cea46695d75e920d36693f9f03103560f10 100644 (file)
@@ -1,26 +1,4 @@
-define Build/netgear-squashfs
-       rm -rf $@.fs $@.squashfs
-       mkdir -p $@.fs/image
-       cp $@ $@.fs/image/uImage
-       $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
-               $@.fs $@.squashfs \
-               -noappend -root-owned -be -b 65536 \
-               $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
-
-       dd if=/dev/zero bs=1k count=1 >> $@.squashfs
-       mkimage \
-               -A mips -O linux -T filesystem -C none \
-               -M $(NETGEAR_KERNEL_MAGIC) \
-               -a 0xbf070000 -e 0xbf070000 \
-               -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
-               -d $@.squashfs $@
-       rm -rf $@.squashfs $@.fs
-endef
-
-define Build/netgear-uImage
-       $(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
-endef
-
+include ./common-netgear.mk
 
 define Device/avm_fritz300e
   ATH_SOC := ar7242