package/kernel: change kmod-libcrc32 dependency to kmod-crypto-crc32c only
authorNicolas Thill <nico@openwrt.org>
Fri, 28 Oct 2011 13:11:01 +0000 (13:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 28 Oct 2011 13:11:01 +0000 (13:11 +0000)
SVN-Revision: 28652

package/kernel/modules/lib.mk

index 5fb779df73a3fc6cf119eef04597bd4f6b26b28c..9154b2eade4989940732fd1070c414751239ffee 100644 (file)
@@ -72,9 +72,9 @@ define KernelPackage/libcrc32c
   SUBMENU:=$(LIB_MENU)
   TITLE:=CRC32 library support
   KCONFIG:=CONFIG_LIBCRC32C
   SUBMENU:=$(LIB_MENU)
   TITLE:=CRC32 library support
   KCONFIG:=CONFIG_LIBCRC32C
-  DEPENDS:=+kmod-crypto-core +kmod-crypto-misc
+  DEPENDS:=+kmod-crypto-crc32c
   FILES:=$(LINUX_DIR)/lib/libcrc32c.ko
   FILES:=$(LINUX_DIR)/lib/libcrc32c.ko
-  AUTOLOAD:=$(call AutoLoad,20,crc32c libcrc32c,1)
+  AUTOLOAD:=$(call AutoLoad,20,libcrc32c,1)
 endef
 
 define KernelPackage/libcrc32c/description
 endef
 
 define KernelPackage/libcrc32c/description