at91: sama5: remove neon and VFPv4 support
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Mon, 2 Apr 2018 16:34:10 +0000 (09:34 -0700)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Apr 2018 07:01:12 +0000 (09:01 +0200)
sama5d2 & samad4 have neon feature and sama5d3 does not have neon
feature due to which sama5d3 boot fails with error message Kernel
panic - not syncing: Attempted to kill init! exitcode=0x00000004.
removing neon & VFPv4 support to fix this

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
target/linux/at91/sama5/target.mk

index 8ff6c761a9267436e0df1bce3875ffc7304c00fa..2e452dc6da2f122d3a18675f609a94120d833cf2 100644 (file)
@@ -1,8 +1,6 @@
-BOARDNAME:=SAMA5 Xplained boards(Cortex-A5)
+BOARDNAME:=SAMA5 boards(Cortex-A5)
 CPU_TYPE:=cortex-a5
-CPU_SUBTYPE:=neon-vfpv4
 
-FEATURES+=fpu
 DEFAULT_PACKAGES += kmod-usb2
 
 define Target/Description