ramips:Add support for Aigale Ai-BR100
authorJohn Crispin <john@openwrt.org>
Sat, 13 Dec 2014 08:07:03 +0000 (08:07 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 13 Dec 2014 08:07:03 +0000 (08:07 +0000)
Aigale Ai-BR100 is a router with mt7620a soc.
There are only 2 lights on the board (WAN and WLAN) so I used the wlan light as the status led.

Signed-off-by: 郭传鈜 <gch981213@gmail.com>
SVN-Revision: 43681

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/AIBR100.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7620/profiles/aigale.mk [new file with mode: 0644]

index bd8c77966014afcb174485d24c6bcd836826634e..9c49c5cda5cfa9eda4635b4544ca6f1a3b688370 100755 (executable)
@@ -27,6 +27,10 @@ case $board in
        3g300m)
                set_usb_led "tenda:blue:3g"
                ;;
+       ai-br100)
+               ucidef_set_led_netdev "wan" "wan" "aigale:blue:wan" "eth0.2"
+               set_wifi_led "aigale:blue:wlan"
+               ;;
        a5-v11)
                ucidef_set_led_default "power" "POWER" "a5-v11:red:power" "1"
                ;;
index b519cfdd3c864032c1049266c6984f3fabc6a530..80b5449e054d15a4d434f4955fd19c6e9802aebf 100755 (executable)
@@ -110,6 +110,7 @@ ramips_setup_interfaces()
                ;;
 
        3g-6200n | \
+       ai-br100 | \
        dir-610-a1 | \
        dir-300-b7 | \
        dir-320-b1 | \
index dfa5468205fa1f458bc3c44bba2495686785ab4b..f50ae1fe7ffe6008cc3df67b8c57ae556d40f83e 100755 (executable)
@@ -12,6 +12,9 @@ get_status_led() {
        3g300m | w150m)
                status_led="tenda:blue:ap"
                ;;
+       ai-br100)
+               status_led="aigale:blue:wlan"
+               ;;
        ar670w)
                status_led="ar670w:green:power"
                ;;
index ff5044c61560a36b030de41a6dac34242c9c9c96..b4e5d91e861f032918f1891dc625716ebb6293c1 100755 (executable)
@@ -28,6 +28,9 @@ ramips_board_detect() {
        *"A5-V11")
                name="a5-v11"
                ;;
+       *"Aigale Ai-BR100")
+               name="ai-br100"
+               ;;
        *"Airlink101 AR670W")
                name="ar670w"
                ;;
index 4962b8b4d080b99856e589f52f73230473a90e98..991d3b556e9c8d6766002a8be64aa1d7b0c021b5 100755 (executable)
@@ -19,6 +19,7 @@ platform_check_image() {
        3g300m | \
        a5-v11 | \
        air3gii | \
+       ai-br100 |\
        all0239-3g | \
        all0256n | \
        all5002 | \
diff --git a/target/linux/ramips/dts/AIBR100.dts b/target/linux/ramips/dts/AIBR100.dts
new file mode 100644 (file)
index 0000000..90f3a1e
--- /dev/null
@@ -0,0 +1,106 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "AIBR100", "ralink,mt7620a-soc";
+       model = "Aigale Ai-BR100";
+
+       palmbus@10000000 {
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "en25q64";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "en25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x20000>;
+                                       read-only;
+                               };
+
+                               partition@20000 {
+                                       label = "u-boot-env";
+                                       reg = <0x20000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@30000 {
+                                       label = "factory";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@40000 {
+                                       label = "firmware";
+                                       reg = <0x40000 0x7c0000>;
+                               };
+                       };
+               };
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               pinctrl-names = "default";
+               pinctrl-0 = <&ephy_pins>;
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "llllw";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               wan {
+                       label = "aigale:blue:wan";
+                       gpios = <&gpio2 4 1>;
+               };
+               wlan {
+                       label = "aigale:blue:wlan";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 12 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
index e0eb8c2d298918bc0049f837121e6f9337dd1aaa..c5478ceaa65b8106a634a05edf8191d3d4d052d0 100644 (file)
@@ -770,6 +770,8 @@ Image/Build/Profile/MT7620a=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a,MT7
 Image/Build/Profile/MT7620a_MT7610e=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_mt7610e,MT7620a_MT7610e)
 Image/Build/Profile/MT7620a_MT7530=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_mt7530,MT7620a_MT7530)
 Image/Build/Profile/MT7620a_V22SG=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_v22sg,MT7620a_V22SG)
+br100_mtd_size=8126464
+Image/Build/Profile/AIBR100=$(call BuildFirmware/CustomFlash/$(1),$(1),ai-br100,AIBR100,$(br100_mtd_size),Ai-BR)
 Image/Build/Profile/RP-N53=$(call BuildFirmware/Default8M/$(1),$(1),rp_n53,RP-N53)
 whr_300hp2_mtd_size=7012352
 Image/Build/Profile/WHR300HP2=$(call BuildFirmware/CustomFlash/$(1),$(1),whr-300hp2,WHR-300HP2,$(whr_300hp2_mtd_size))
@@ -799,6 +801,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/MT7620a_MT7610e,$(1))
        $(call Image/Build/Profile/MT7620a_MT7530,$(1))
        $(call Image/Build/Profile/MT7620a_V22SG,$(1))
+       $(call Image/Build/Profile/AIBR100,$(1))
        $(call Image/Build/Profile/RP-N53,$(1))
        $(call Image/Build/Profile/DIR-810L,$(1))
        $(call Image/Build/Profile/WHR300HP2,$(1))
diff --git a/target/linux/ramips/mt7620/profiles/aigale.mk b/target/linux/ramips/mt7620/profiles/aigale.mk
new file mode 100644 (file)
index 0000000..475aac9
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/AIBR100
+       NAME:=Aigale Ai-BR100
+       PACKAGES:=kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/AIBR100/Description
+       Default package set for Aigale Ai-BR100.
+endef
+$(eval $(call Profile,AIBR100))