dhcp: send 6rd-ORO when expecting 6rd-information
authorSteven Barth <cyrus@openwrt.org>
Wed, 26 Mar 2014 09:48:20 +0000 (09:48 +0000)
committerSteven Barth <cyrus@openwrt.org>
Wed, 26 Mar 2014 09:48:20 +0000 (09:48 +0000)
SVN-Revision: 40019

package/network/config/netifd/Makefile
package/network/config/netifd/files/lib/netifd/proto/dhcp.sh

index 75314f161d3e8892009e03fd43725f06c21060b1..8414ff91b411c85385fa91bc2ac6404fad9c13c3 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2014-03-21
+PKG_VERSION:=2014-03-26
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
index 0481d05132133287928e3aeb8d6135c470782c46..80c3562e69a36e380738ab6af68f53411fe86867 100755 (executable)
@@ -36,6 +36,7 @@ proto_dhcp_setup() {
        [ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
        [ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
        [ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
+       [ -n "$iface6rd" ] && append dhcpopts "-O 212"
        [ "$delegate" = "0" ] && proto_export "IFACE6RD_DELEGATE=0"
 
        proto_export "INTERFACE=$config"