openssl: bump to 1.0.2
authorSteven Barth <cyrus@openwrt.org>
Mon, 9 Feb 2015 12:04:00 +0000 (12:04 +0000)
committerSteven Barth <cyrus@openwrt.org>
Mon, 9 Feb 2015 12:04:00 +0000 (12:04 +0000)
Fixes CVE-2014-3513, CVE-2014-3567, CVE-2014-3568, CVE-2014-3566

Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 44332

package/libs/openssl/Makefile
package/libs/openssl/patches/110-optimize-for-size.patch
package/libs/openssl/patches/130-perl-path.patch
package/libs/openssl/patches/140-makefile-dirs.patch
package/libs/openssl/patches/150-no_engines.patch
package/libs/openssl/patches/160-disable_doc_tests.patch
package/libs/openssl/patches/190-remove_timestamp_check.patch
package/libs/openssl/patches/200-parallel_build.patch
package/libs/openssl/patches/210-termios_fix.patch

index 3e556140d849be29f13703f75383c6d56bde916a..7a21e51c5fdb8b2ceedc56450eabb6de1a8f9924 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=1.0.1l
+PKG_VERSION:=1.0.2
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
@@ -18,7 +18,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=cdb22925fc9bc97ccbf1e007661f2aa6
+PKG_MD5SUM:=38373013fc85c790aabf8837969c5eba
 
 PKG_LICENSE:=OpenSSL
 PKG_LICENSE_FILES:=LICENSE
 
 PKG_LICENSE:=OpenSSL
 PKG_LICENSE_FILES:=LICENSE
index 268381978b7d16f531ad22264086084e9bbc1eab..b0adfc153f9a2604aa84c028c28e15afb54a56f9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Configure
 +++ b/Configure
 --- a/Configure
 +++ b/Configure
-@@ -403,6 +403,11 @@ my %table=(
+@@ -443,6 +443,11 @@ my %table=(
  "linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
  "linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
  
  "linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
  "linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
  
index dd4fa54d55d3169e6473791d5f11bddf4e9fde8b..2dbdc7601027017a6860172b53f89124af69a311 100644 (file)
@@ -12,8 +12,8 @@
 -#!/usr/local/bin/perl
 +#!/usr/bin/perl
  
 -#!/usr/local/bin/perl
 +#!/usr/bin/perl
  
  # Perl c_rehash script, scan all files in a directory
  # Perl c_rehash script, scan all files in a directory
+ # and add symbolic links to their hash values.
 --- a/util/clean-depend.pl
 +++ b/util/clean-depend.pl
 @@ -1,4 +1,4 @@
 --- a/util/clean-depend.pl
 +++ b/util/clean-depend.pl
 @@ -1,4 +1,4 @@
index b51ca28b627f292bd0c1c392a2c096ee00302d17..7503dfc1f6180e889c94127b7127058e42aa403e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.org
 +++ b/Makefile.org
 --- a/Makefile.org
 +++ b/Makefile.org
-@@ -135,7 +135,7 @@ FIPSCANLIB=
+@@ -136,7 +136,7 @@ FIPSCANLIB=
  
  BASEADDR=
  
  
  BASEADDR=
  
index 161cd29c0843e1218ce6ec5243885bd4fb85f9f1..790da30b3195c0e58e789425b7eba515e34eb04e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Configure
 +++ b/Configure
 --- a/Configure
 +++ b/Configure
-@@ -2017,6 +2017,11 @@ EOF
+@@ -2075,6 +2075,11 @@ EOF
        close(OUT);
    }
    
        close(OUT);
    }
    
index 54f58fb5a4704d961c02bdc5f129321a847477fc..e31ffa5815bf36c0aff95c00e4d5933107660241 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
 --- a/Makefile
 +++ b/Makefile
-@@ -137,7 +137,7 @@ FIPSCANLIB=
+@@ -138,7 +138,7 @@ FIPSCANLIB=
  
  BASEADDR=0xFB00000
  
  
  BASEADDR=0xFB00000
  
@@ -9,7 +9,7 @@
  ENGDIRS= ccgost
  SHLIBDIRS= crypto ssl
  
  ENGDIRS= ccgost
  SHLIBDIRS= crypto ssl
  
-@@ -155,7 +155,7 @@ SDIRS=  \
+@@ -156,7 +156,7 @@ SDIRS=  \
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
@@ -18,7 +18,7 @@
  
  MAKEFILE= Makefile
  
  
  MAKEFILE= Makefile
  
-@@ -169,7 +169,7 @@ SHELL=/bin/sh
+@@ -170,7 +170,7 @@ SHELL=/bin/sh
  
  TOP=    .
  ONEDIRS=out tmp
  
  TOP=    .
  ONEDIRS=out tmp
@@ -27,7 +27,7 @@
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
  SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
  SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
-@@ -270,7 +270,7 @@ reflect:
+@@ -271,7 +271,7 @@ reflect:
        @[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
  
  sub_all: build_all
        @[ -n "$(THIS)" ] && $(CLEARENV) && $(MAKE) $(THIS) -e $(BUILDENV)
  
  sub_all: build_all
@@ -36,7 +36,7 @@
  
  build_libs: build_crypto build_ssl build_engines
  
  
  build_libs: build_crypto build_ssl build_engines
  
-@@ -540,7 +540,7 @@ dist:
+@@ -538,7 +538,7 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -47,7 +47,7 @@
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
 --- a/Makefile.org
 +++ b/Makefile.org
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
 --- a/Makefile.org
 +++ b/Makefile.org
-@@ -538,7 +538,7 @@ dist:
+@@ -536,7 +536,7 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
index 460068840e3668233ba71ff386b3f658397cbd42..86b17d03402377769663b663c3426629205f6594 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.org
 +++ b/Makefile.org
 --- a/Makefile.org
 +++ b/Makefile.org
-@@ -184,7 +184,7 @@ WTARFILE=       $(NAME)-win.tar
+@@ -185,7 +185,7 @@ WTARFILE=       $(NAME)-win.tar
  EXHEADER=       e_os2.h
  HEADER=         e_os.h
  
  EXHEADER=       e_os2.h
  HEADER=         e_os.h
  
@@ -9,9 +9,9 @@
  
  # as we stick to -e, CLEARENV ensures that local variables in lower
  # Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
  
  # as we stick to -e, CLEARENV ensures that local variables in lower
  # Makefiles remain local and variable. $${VAR+VAR} is tribute to Korn
-@@ -397,11 +397,6 @@ openssl.pc: Makefile
-           echo 'Libs.private: $(EX_LIBS)'; \
-           echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
+@@ -395,11 +395,6 @@ openssl.pc: Makefile
+           echo 'Version: '$(VERSION); \
+           echo 'Requires: libssl libcrypto' ) > openssl.pc
  
 -Makefile: Makefile.org Configure config
 -      @echo "Makefile is older than Makefile.org, Configure or config."
  
 -Makefile: Makefile.org Configure config
 -      @echo "Makefile is older than Makefile.org, Configure or config."
index b63e5eea634ef9cfb33daa786e4c29506f4553ee..0416eabdc6bb7e1e7fc3e99a26fcdd00a9b456f8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.org
 +++ b/Makefile.org
 --- a/Makefile.org
 +++ b/Makefile.org
-@@ -273,17 +273,17 @@ build_all: build_libs build_apps build_t
+@@ -274,17 +274,17 @@ build_all: build_libs build_apps build_t
  build_libs: build_crypto build_ssl build_engines
  
  build_crypto:
  build_libs: build_crypto build_ssl build_engines
  
  build_crypto:
@@ -29,7 +29,7 @@
  
  all_testapps: build_libs build_testapps
  build_testapps:
  
  all_testapps: build_libs build_testapps
  build_testapps:
-@@ -455,7 +455,7 @@ report:
+@@ -453,7 +453,7 @@ report:
        @$(PERL) util/selftest.pl
  
  depend:
        @$(PERL) util/selftest.pl
  
  depend:
@@ -38,7 +38,7 @@
  
  lint:
        @set -e; target=lint; $(RECURSIVE_BUILD_CMD)
  
  lint:
        @set -e; target=lint; $(RECURSIVE_BUILD_CMD)
-@@ -533,9 +533,9 @@ dist:
+@@ -531,9 +531,9 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -50,7 +50,7 @@
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
                $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
                $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
                $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
                $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
-@@ -544,12 +544,19 @@ install_sw:
+@@ -542,12 +542,19 @@ install_sw:
                $(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
                $(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
                $(INSTALL_PREFIX)$(OPENSSLDIR)/private
                $(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
                $(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
                $(INSTALL_PREFIX)$(OPENSSLDIR)/private
@@ -71,7 +71,7 @@
        @set -e; liblist="$(LIBS)"; for i in $$liblist ;\
        do \
                if [ -f "$$i" ]; then \
        @set -e; liblist="$(LIBS)"; for i in $$liblist ;\
        do \
                if [ -f "$$i" ]; then \
-@@ -629,12 +636,7 @@ install_html_docs:
+@@ -631,12 +638,7 @@ install_html_docs:
                done; \
        done
  
                done; \
        done
  
 +      +@target=all; $(RECURSIVE_MAKE)
  
  files:
 +      +@target=all; $(RECURSIVE_MAKE)
  
  files:
-       $(PERL) $(TOP)/util/files.pl Makefile >> $(TOP)/MINFO
+       $(PERL) $(TOP)/util/files.pl "CPUID_OBJ=$(CPUID_OBJ)" Makefile >> $(TOP)/MINFO
 -      @target=files; $(RECURSIVE_MAKE)
 +      +@target=files; $(RECURSIVE_MAKE)
  
 -      @target=files; $(RECURSIVE_MAKE)
 +      +@target=files; $(RECURSIVE_MAKE)
  
 -$(LIB):       $(LIBOBJ)
 +$(LIB):       $(LIBOBJ) | subdirs
        $(AR) $(LIB) $(LIBOBJ)
 -$(LIB):       $(LIBOBJ)
 +$(LIB):       $(LIBOBJ) | subdirs
        $(AR) $(LIB) $(LIBOBJ)
-       [ -z "$(FIPSLIBDIR)" ] || $(AR) $(LIB) $(FIPSLIBDIR)fipscanister.o
+       test -z "$(FIPSLIBDIR)" || $(AR) $(LIB) $(FIPSLIBDIR)fipscanister.o
        $(RANLIB) $(LIB) || echo Never mind.
 @@ -111,7 +111,7 @@ shared: buildinf.h lib subdirs
        fi
        $(RANLIB) $(LIB) || echo Never mind.
 @@ -111,7 +111,7 @@ shared: buildinf.h lib subdirs
        fi
        ctags $(SRC)
 --- a/test/Makefile
 +++ b/test/Makefile
        ctags $(SRC)
 --- a/test/Makefile
 +++ b/test/Makefile
-@@ -129,7 +129,7 @@ install:
+@@ -132,7 +132,7 @@ install:
  tags:
        ctags $(SRC)
  
  tags:
        ctags $(SRC)
  
  
  apps:
        @(cd ..; $(MAKE) DIRS=apps all)
  
  apps:
        @(cd ..; $(MAKE) DIRS=apps all)
-@@ -384,109 +384,109 @@ BUILD_CMD_STATIC=shlib_target=; \
+@@ -398,109 +398,109 @@ BUILD_CMD_STATIC=shlib_target=; \
                link_app.$${shlib_target}
  
  $(RSATEST)$(EXE_EXT): $(RSATEST).o $(DLIBCRYPTO)
                link_app.$${shlib_target}
  
  $(RSATEST)$(EXE_EXT): $(RSATEST).o $(DLIBCRYPTO)
 -      @target=$(SRPTEST); $(BUILD_CMD)
 +      +@target=$(SRPTEST); $(BUILD_CMD)
  
 -      @target=$(SRPTEST); $(BUILD_CMD)
 +      +@target=$(SRPTEST); $(BUILD_CMD)
  
- $(HEARTBEATTEST)$(EXE_EXT): $(HEARTBEATTEST).o $(DLIBCRYPTO)
-       @target=$(HEARTBEATTEST); $(BUILD_CMD_STATIC)
-@@ -505,7 +505,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
+ $(V3NAMETEST)$(EXE_EXT): $(V3NAMETEST).o $(DLIBCRYPTO)
+       @target=$(V3NAMETEST); $(BUILD_CMD)
+@@ -522,7 +522,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
  #     fi
  
  dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)
  #     fi
  
  dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)
index f14960ca33612e2caaddc947fad72ae3b34ceae8..957c5cf25cb6f8147843a402f5e8d33189366a21 100644 (file)
@@ -1,6 +1,6 @@
 --- a/crypto/ui/ui_openssl.c
 +++ b/crypto/ui/ui_openssl.c
 --- a/crypto/ui/ui_openssl.c
 +++ b/crypto/ui/ui_openssl.c
-@@ -190,7 +190,7 @@
+@@ -194,7 +194,7 @@
  # undef  SGTTY
  #endif
  
  # undef  SGTTY
  #endif