Revert "wolfssl: use dynamic ABI_VERSION depending on the configuration and package...
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 14 Feb 2021 23:28:35 +0000 (00:28 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 15 Feb 2021 00:15:49 +0000 (01:15 +0100)
This fixes the build on MIPS BE like ath25 and ath79 target.
We get this error message when linking libwolfssl:
mips-openwrt-linux-musl/bin/ld: /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libwolfssl.so: unknown type [0x7000002a] section `.MIPS.abiflags'
mips-openwrt-linux-musl/bin/ld: /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libwolfssl.so: unknown type [0x7000002a] section `.MIPS.abiflags'
mips-openwrt-linux-musl/bin/ld: skipping incompatible /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libwolfssl.so when searching for -lwolfssl
mips-openwrt-linux-musl/bin/ld: cannot find -lwolfssl
collect2: error: ld returned 1 exit status

This reverts commit 2591c83b3406c16d3c1cd2dc7fa59c3c1b901d3c.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/libs/wolfssl/Makefile

index 51dc4d5a0933ce190658012303c07d34c3c013b9..ff01fca663104dbf6a75b72a1c3fd973499eb94e 100644 (file)
@@ -33,8 +33,6 @@ PKG_CONFIG_DEPENDS:=\
        CONFIG_WOLFSSL_HAS_SESSION_TICKET CONFIG_WOLFSSL_HAS_TLSV10 \
        CONFIG_WOLFSSL_HAS_TLSV13 CONFIG_WOLFSSL_HAS_WPAS CONFIG_WOLFSSL_HAS_CERTGEN
 
-PKG_ABI_VERSION=$(patsubst %-stable,%,$(PKG_VERSION)).$(call version_abbrev,$(call confvar,$(PKG_CONFIG_DEPENDS)))
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libwolfssl
@@ -46,7 +44,7 @@ define Package/libwolfssl
   MENU:=1
   PROVIDES:=libcyassl
   DEPENDS:=+WOLFSSL_HAS_DEVCRYPTO:kmod-cryptodev +WOLFSSL_HAS_AFALG:kmod-crypto-user
-  ABI_VERSION:=$(PKG_ABI_VERSION)
+  ABI_VERSION:=24
 endef
 
 define Package/libwolfssl/description