kernel: bump 5.4 to 5.4.156
authorJohn Audia <graysky@archlinux.us>
Sun, 31 Oct 2021 11:08:40 +0000 (07:08 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Nov 2021 13:48:20 +0000 (14:48 +0100)
Removed upstreamed:
  backport-5.4/790-v5.7-net-switchdev-do-not-propagate-bridge-updates-across.patch

All other patches automatically rebased.

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/generic/backport-5.4/782-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/generic/backport-5.4/790-v5.7-net-switchdev-do-not-propagate-bridge-updates-across.patch [deleted file]
target/linux/generic/hack-5.4/220-arm-gc_sections.patch
target/linux/pistachio/patches-5.4/401-mtd-nor-support-mtd-name-from-device-tree.patch

index 17cb009f3c54b25759e175d5fc5a7f9e6c82c0fc..cb4d19558800e122dfc4bca885ae8caca5c29d46 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .155
+LINUX_VERSION-5.4 = .156
 LINUX_VERSION-5.10 = .77
 
-LINUX_KERNEL_HASH-5.4.155 = cc0c0f902748d251cb22d0e69e3b8d260c447eb0072ef853da15da6cce775038
+LINUX_KERNEL_HASH-5.4.156 = 06fe73e4623fcf1b3c0d0e1983d8286a2ff5b8fffbcb2163f4c01696a1c377fe
 LINUX_KERNEL_HASH-5.10.77 = d3b64edfc1dd7212e62ed733aeeb73d64ffd6d9658d322d44cddf1b41d5b8fc3
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 3847610df5719622ef706b2051e905dc0dd36322..bf0ff9eddf5d4802de055c0a3a39db5f999195c2 100644 (file)
@@ -1340,7 +1340,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
  
        plat->phy_interface = of_get_phy_mode(np);
-@@ -631,7 +631,7 @@ void stmmac_remove_config_dt(struct plat
+@@ -639,7 +639,7 @@ void stmmac_remove_config_dt(struct plat
  }
  #else
  struct plat_stmmacenet_data *
diff --git a/target/linux/generic/backport-5.4/790-v5.7-net-switchdev-do-not-propagate-bridge-updates-across.patch b/target/linux/generic/backport-5.4/790-v5.7-net-switchdev-do-not-propagate-bridge-updates-across.patch
deleted file mode 100644 (file)
index bc8014b..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-From 07c6f9805f12f1bb538ef165a092b300350384aa Mon Sep 17 00:00:00 2001
-From: Russell King <rmk+kernel@armlinux.org.uk>
-Date: Wed, 26 Feb 2020 17:14:21 +0000
-Subject: [PATCH] net: switchdev: do not propagate bridge updates across
- bridges
-
-When configuring a tree of independent bridges, propagating changes
-from the upper bridge across a bridge master to the lower bridge
-ports brings surprises.
-
-For example, a lower bridge may have vlan filtering enabled.  It
-may have a vlan interface attached to the bridge master, which may
-then be incorporated into another bridge.  As soon as the lower
-bridge vlan interface is attached to the upper bridge, the lower
-bridge has vlan filtering disabled.
-
-This occurs because switchdev recursively applies its changes to
-all lower devices no matter what.
-
-Reviewed-by: Ido Schimmel <idosch@mellanox.com>
-Tested-by: Ido Schimmel <idosch@mellanox.com>
-Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
-Reviewed-by: Florian Fainelli <f.fainelli@gmail.com>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- net/switchdev/switchdev.c | 9 +++++++++
- 1 file changed, 9 insertions(+)
-
---- a/net/switchdev/switchdev.c
-+++ b/net/switchdev/switchdev.c
-@@ -476,6 +476,9 @@ static int __switchdev_handle_port_obj_a
-        * necessary to go through this helper.
-        */
-       netdev_for_each_lower_dev(dev, lower_dev, iter) {
-+              if (netif_is_bridge_master(lower_dev))
-+                      continue;
-+
-               err = __switchdev_handle_port_obj_add(lower_dev, port_obj_info,
-                                                     check_cb, add_cb);
-               if (err && err != -EOPNOTSUPP)
-@@ -528,6 +531,9 @@ static int __switchdev_handle_port_obj_d
-        * necessary to go through this helper.
-        */
-       netdev_for_each_lower_dev(dev, lower_dev, iter) {
-+              if (netif_is_bridge_master(lower_dev))
-+                      continue;
-+
-               err = __switchdev_handle_port_obj_del(lower_dev, port_obj_info,
-                                                     check_cb, del_cb);
-               if (err && err != -EOPNOTSUPP)
-@@ -579,6 +585,9 @@ static int __switchdev_handle_port_attr_
-        * necessary to go through this helper.
-        */
-       netdev_for_each_lower_dev(dev, lower_dev, iter) {
-+              if (netif_is_bridge_master(lower_dev))
-+                      continue;
-+
-               err = __switchdev_handle_port_attr_set(lower_dev, port_attr_info,
-                                                      check_cb, set_cb);
-               if (err && err != -EOPNOTSUPP)
index 70457ab73a5414b4a332eb201f623f4f10b4bf19..14e2461797979c6de3d3eb91c3e3125a3bdc465f 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -111,6 +111,7 @@ config ARM
+@@ -112,6 +112,7 @@ config ARM
        select HAVE_UID16
        select HAVE_VIRT_CPU_ACCOUNTING_GEN
        select IRQ_FORCED_THREADING
index 69a8303d2bc3a459850798a629cdb29da70603d5..cdf0e49b21cfe520fa2662cf53f2b7f32506fa32 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -4938,6 +4938,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -4939,6 +4939,7 @@ int spi_nor_scan(struct spi_nor *nor, co
        struct mtd_info *mtd = &nor->mtd;
        struct device_node *np = spi_nor_get_flash_node(nor);
        struct spi_nor_flash_parameter *params = &nor->params;
@@ -18,7 +18,7 @@ Signed-off-by: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
        int ret;
        int i;
  
-@@ -5000,7 +5001,12 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -5001,7 +5002,12 @@ int spi_nor_scan(struct spi_nor *nor, co
        /* Init flash parameters based on flash_info struct and SFDP */
        spi_nor_init_params(nor);