update to 2.6.35.11
authorFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 12:44:16 +0000 (12:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 19 Feb 2011 12:44:16 +0000 (12:44 +0000)
SVN-Revision: 25582

include/kernel-version.mk
target/linux/at91/Makefile
target/linux/au1000/Makefile
target/linux/brcm63xx/Makefile
target/linux/generic/patches-2.6.35/040-arm-update-mach-types.patch
target/linux/generic/patches-2.6.35/240-packet_socket_type.patch
target/linux/generic/patches-2.6.35/801-usb_serial_endpoint_size.patch
target/linux/generic/patches-2.6.35/980-vm_exports.patch
target/linux/kirkwood/Makefile
target/linux/lantiq/Makefile

index 7e0eee1350c5d440fa6d5f04946ff54d9e0dfb16..b7707d3322e847de14aed1269c57ca08e44606ed 100644 (file)
@@ -14,8 +14,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.34.7)
   LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
 endif
-ifeq ($(LINUX_VERSION),2.6.35.9)
-  LINUX_KERNEL_MD5SUM:=18d339e9229560e73c4249dffdc3fd90
+ifeq ($(LINUX_VERSION),2.6.35.11)
+  LINUX_KERNEL_MD5SUM:=4c9ee33801f5ad0f4d5e615fac66d535
 endif
 ifeq ($(LINUX_VERSION),2.6.36.4)
   LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
index d06bb842e38ea359950794af95533e220f6529f1..0ef55e6410c2167df2018288a227989322462e1b 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
 SUBTARGETS:=netus tqma9263
 
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index b2b134179302881b7afcfe8c132e22f453194b71..a30f6b65ef0ddde2b8631554f70a04799c1dafff 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index 81e30f3a158f71b95fb4660c1d32c8e6721db086..e5e2d55dd3feb629a099c1ab5aa965687aa6664c 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
 
 include $(INCLUDE_DIR)/target.mk
 
index c00886e5936d89925497ef1c6c39e5118dfd8ab7..014bb256a40392253596db3ef22061f56811d852 100644 (file)
@@ -81,7 +81,7 @@
  htc_excalibur_s620    MACH_HTC_EXCALIBUR_S620 HTC_EXCALIBUR_S620      2391
  htc_opal              MACH_HTC_OPAL           HTC_OPAL                2392
  touchbook             MACH_TOUCHBOOK          TOUCHBOOK               2393
-@@ -2446,7 +2446,7 @@ siogentoo1               MACH_SIOGENTOO1         SIOGENTOO1      
+@@ -2446,7 +2446,7 @@ siogentoo1               MACH_SIOGENTOO1         SIOGENTOO1
  siogentoo2            MACH_SIOGENTOO2         SIOGENTOO2              2459
  sm3k                  MACH_SM3K               SM3K                    2460
  acer_tempo_f900               MACH_ACER_TEMPO_F900    ACER_TEMPO_F900         2461
index 44117659a4f6cc13fb3e8fd6ccc0e74f6d33516f..7093031b1c8ad76232e5efe450fb1db960a9df62 100644 (file)
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -2027,6 +2031,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -2030,6 +2034,16 @@ packet_setsockopt(struct socket *sock, i
                po->has_vnet_hdr = !!val;
                return 0;
        }
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        default:
                return -ENOPROTOOPT;
        }
-@@ -2084,6 +2098,13 @@ static int packet_getsockopt(struct sock
+@@ -2087,6 +2101,13 @@ static int packet_getsockopt(struct sock
  
                data = &val;
                break;
index cfbcbe88fb7c4ec1f9a148318937f3458f0b1a59..735c4e355b3feda44afb0444c0a183b20cf041dc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/serial/usb-serial.c
 +++ b/drivers/usb/serial/usb-serial.c
-@@ -61,6 +61,7 @@ static struct usb_driver usb_serial_driv
+@@ -62,6 +62,7 @@ static struct usb_driver usb_serial_driv
     drivers depend on it.
  */
  
@@ -8,7 +8,7 @@
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -912,7 +913,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -913,7 +914,7 @@ int usb_serial_probe(struct usb_interfac
                }
                buffer_size = serial->type->bulk_in_size;
                if (!buffer_size)
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1382,3 +1383,5 @@ MODULE_LICENSE("GPL");
+@@ -1385,3 +1386,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 5ca94b25a2d71cd98762be2e09fcd222845998ac..169bf4301018ab0c43ed898ead4f3da9616275ba 100644 (file)
@@ -48,7 +48,7 @@
  {
 --- a/kernel/exit.c
 +++ b/kernel/exit.c
-@@ -506,6 +506,7 @@ struct files_struct *get_files_struct(st
+@@ -514,6 +514,7 @@ struct files_struct *get_files_struct(st
  
        return files;
  }
@@ -56,7 +56,7 @@
  
  void put_files_struct(struct files_struct *files)
  {
-@@ -527,6 +528,7 @@ void put_files_struct(struct files_struc
+@@ -535,6 +536,7 @@ void put_files_struct(struct files_struc
                rcu_read_unlock();
        }
  }
@@ -76,7 +76,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4262,6 +4262,7 @@ int can_nice(const struct task_struct *p
+@@ -4390,6 +4390,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
index 1dbd5b14501ad95188cac42dc04105859bb400ad..101cea3b7432a10888ae3bca270c89085b6f634e 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell Kirkwood
 FEATURES:=targz usb jffs2
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
 
 include $(INCLUDE_DIR)/target.mk
 
index 5afe5662da8fe4c6aa010e597fff12de22d99ed2..309b31a1648e746d96b33215bab807a2c8ffaa0d 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2 atm
 SUBTARGETS:=xway
 
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.35.11
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time