kernel: refresh 3.10 patches
authorFelix Fietkau <nbd@openwrt.org>
Mon, 15 Jul 2013 15:12:37 +0000 (15:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 15 Jul 2013 15:12:37 +0000 (15:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37348

26 files changed:
target/linux/generic/patches-3.10/204-module_strip.patch
target/linux/generic/patches-3.10/230-openwrt_lzma_options.patch
target/linux/generic/patches-3.10/304-mips_disable_fpu.patch
target/linux/generic/patches-3.10/306-mips_mem_functions_performance.patch
target/linux/generic/patches-3.10/401-partial_eraseblock_write.patch
target/linux/generic/patches-3.10/410-mtd_info_move_forward_decl.patch
target/linux/generic/patches-3.10/430-mtd_myloader_partition_parser.patch
target/linux/generic/patches-3.10/470-mtd_m25p80_add_pm25lv_flash_support.patch
target/linux/generic/patches-3.10/476-mtd-m25p80-allow-to-disable-small-sector-erase.patch
target/linux/generic/patches-3.10/478-mtd-partial_eraseblock_unlock.patch
target/linux/generic/patches-3.10/504-yaffs-Mods-for-Linux-3.0-and-fix-a-typo.patch
target/linux/generic/patches-3.10/512-yaffs-3.5-convert-to-use-kuid_t-kgid_t.patch
target/linux/generic/patches-3.10/531-debloat_lzma.patch
target/linux/generic/patches-3.10/600-netfilter_layer7_2.22.patch
target/linux/generic/patches-3.10/604-netfilter_conntrack_flush.patch
target/linux/generic/patches-3.10/610-netfilter_match_bypass_default_checks.patch
target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-3.10/644-bridge_optimize_netfilter_hooks.patch
target/linux/generic/patches-3.10/653-disable_netlink_trim.patch
target/linux/generic/patches-3.10/657-qdisc_reduce_truesize.patch
target/linux/generic/patches-3.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-3.10/750-hostap_txpower.patch
target/linux/generic/patches-3.10/810-pci_disable_common_quirks.patch
target/linux/generic/patches-3.10/902-debloat_proc.patch
target/linux/generic/patches-3.10/941-ocf_20120127.patch
target/linux/generic/patches-3.10/992-mpcore_wdt_fix_watchdog_counter_loading.patch

index e4d5407c8e60f27f2d22bd06217b2b3f42091e5d..74a4254249682087e6e61e273b42af8a1ab67127 100644 (file)
@@ -78,7 +78,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  #ifdef MODULE
  #define __MODULE_INFO(tag, name, info)                                          \
  static const char __UNIQUE_ID(name)[]                                   \
-@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
+@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]                        
    = __stringify(tag) "=" info
  #else  /* !MODULE */
  /* This struct is here for syntactic coherency, it is not used */
@@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  #endif
  #define __MODULE_PARM_TYPE(name, _type)                                         \
    __MODULE_INFO(parmtype, name##type, #name ":" _type)
-@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
+@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]                        
  /* One for each parameter, describing how to use it.  Some files do
     multiple of these per line, so can't just use MODULE_INFO. */
  #define MODULE_PARM_DESC(_parm, desc) \
index dc491ffebc62bf2c99a13f8ea036ed5d73240f05..ff38fc6085f8a0738055ccee16d509dc0ba390ec 100644 (file)
@@ -1,6 +1,6 @@
 --- a/scripts/Makefile.lib
 +++ b/scripts/Makefile.lib
-@@ -303,7 +303,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+@@ -303,7 +303,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^) 
  
  quiet_cmd_lzma = LZMA    $@
  cmd_lzma = (cat $(filter-out FORCE,$^) | \
index c540ba0f7d28e628f032c3c4b9d21be1795f5734..33fd6a91eb48759fba16399f6cce5cb96aa6d733 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
  /* Convert Mips rounding mode (0..3) to IEEE library modes. */
  static const unsigned char ieee_rm[4] = {
        [FPU_CSR_RN] = IEEE754_RN,
-@@ -116,9 +120,13 @@ static const unsigned int fpucondbit[8]
+@@ -116,9 +120,13 @@ static const unsigned int fpucondbit[8] 
  };
  #endif
  
index 981867742531547c11ed4ac124494f5820eae79a..e6056fa5c409f1181b854ef7187f1d1ece0249cf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/include/asm/string.h
 +++ b/arch/mips/include/asm/string.h
-@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
+@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__ 
  
  #define __HAVE_ARCH_MEMSET
  extern void *memset(void *__s, int __c, size_t __count);
index f2fa3676fbf552fe6ab00758bb872adf31ce3adf..fbc2d5f0e1f234d44553615f734400f3107f81ff 100644 (file)
@@ -9,7 +9,7 @@
  /* Our partition linked list */
  static LIST_HEAD(mtd_partitions);
  static DEFINE_MUTEX(mtd_partitions_mutex);
-@@ -230,13 +232,60 @@ static int part_erase(struct mtd_info *m
+@@ -232,13 +234,60 @@ static int part_erase(struct mtd_info *m
        struct mtd_part *part = PART(mtd);
        int ret;
  
@@ -70,7 +70,7 @@
        return ret;
  }
  
-@@ -244,7 +293,25 @@ void mtd_erase_callback(struct erase_inf
+@@ -246,7 +295,25 @@ void mtd_erase_callback(struct erase_inf
  {
        if (instr->mtd->_erase == part_erase) {
                struct mtd_part *part = PART(instr->mtd);
@@ -96,7 +96,7 @@
                if (instr->fail_addr != MTD_FAIL_ADDR_UNKNOWN)
                        instr->fail_addr -= part->offset;
                instr->addr -= part->offset;
-@@ -504,18 +571,24 @@ static struct mtd_part *allocate_partiti
+@@ -506,18 +573,24 @@ static struct mtd_part *allocate_partiti
        if ((slave->mtd.flags & MTD_WRITEABLE) &&
            mtd_mod_by_eb(slave->offset, &slave->mtd)) {
                /* Doesn't start on a boundary of major erase size */
index 251f522e445f6ea05b40c72f3cf5b67821f51971..4657b43abe667f75ce1bfec0ef74165a981c0c11 100644 (file)
@@ -6,9 +6,9 @@
   */
 +struct mtd_info;
  
- struct mtd_partition;
  struct mtd_partition {
-@@ -52,7 +53,6 @@ struct mtd_partition {
+       char *name;                     /* identifier string */
+@@ -50,7 +51,6 @@ struct mtd_partition {
  #define MTDPART_SIZ_FULL      (0)
  
  
index 8ab8d579965e1d3f2fe6046703249e2274e445f2..026ba2b41a9413da50cde6a136f7569bbf1b1a3d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -163,6 +163,22 @@ config MTD_BCM47XX_PARTS
+@@ -172,6 +172,22 @@ config MTD_BCM47XX_PARTS
          This provides partitions parser for devices based on BCM47xx
          boards.
  
index 8d938d7a5d19c971d5b7c7ba8262c80b0352472b..55c58d5173e30af1a61ab8ebd78786121516c998 100644 (file)
@@ -27,7 +27,7 @@
        /* Spansion -- single (large) sector size only, at least
         * for the chips listed here (without boot sectors).
         */
-@@ -1018,6 +1024,9 @@ static int m25p_probe(struct spi_device
+@@ -1018,6 +1024,9 @@ static int m25p_probe(struct spi_device 
        if (info->flags & SECT_4K) {
                flash->erase_opcode = OPCODE_BE_4K;
                flash->mtd.erasesize = 4096;
index 726c1eb1e8a67884d6bdc71f02f41de0b3554919..89e443708fbb3e9cdac36b58d63ba7738afc33eb 100644 (file)
@@ -30,7 +30,7 @@
  /****************************************************************************/
  
  struct m25p {
-@@ -1022,7 +1028,7 @@ static int m25p_probe(struct spi_device
+@@ -1022,7 +1028,7 @@ static int m25p_probe(struct spi_device 
                flash->mtd._write = m25p80_write;
  
        /* prefer "small sector" erase if possible */
index 0fc4154fa6279d74625d729d7c0f06898c149f2e..87c8257fe115d55ae72c1476d01f9288591ecc59 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -330,7 +330,14 @@ static int part_lock(struct mtd_info *mt
+@@ -332,7 +332,14 @@ static int part_lock(struct mtd_info *mt
  static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
  {
        struct mtd_part *part = PART(mtd);
index 1b814e97fd6a0f8df6c8177f3d5677432e3ab4e7..4767e769b6321a3a40ba2c74fc5ff3c4c5cf0d52 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Charles Manning <cdhmanning@gmail.com>
  #include <linux/pagemap.h>
  #include <linux/mtd/mtd.h>
  #include <linux/interrupt.h>
-@@ -236,7 +238,9 @@ static int yaffs_file_flush(struct file
+@@ -236,7 +238,9 @@ static int yaffs_file_flush(struct file 
  static int yaffs_file_flush(struct file *file);
  #endif
  
index 1ca189d2eec994b0cfdbe18f16a8f971c540c289..7787d500a9470162bde5bf4e6f70d336de587e9d 100644 (file)
        result = yaffs_rd_chunk_tags_nand(dev,nand_chunk,buffer,&tempTags);
        if(memcmp(buffer,data,dev->data_bytes_per_chunk) ||
                tempTags.obj_id != tags->obj_id ||
-@@ -424,7 +424,7 @@ static int yaffs_write_new_chunk(struct
+@@ -424,7 +424,7 @@ static int yaffs_write_new_chunk(struct 
                 * lot of checks that are most likely not needed.
                 *
                 * Mods to the above
                 * rest of the block.
                 */
  
-@@ -486,7 +486,7 @@ static int yaffs_write_new_chunk(struct
+@@ -486,7 +486,7 @@ static int yaffs_write_new_chunk(struct 
  }
  
  
                                        /* Free chunks already includes softdeleted chunks.
                                         * How ever this chunk is going to soon be really deleted
                                         * which will increment free chunks.
-@@ -2752,7 +2752,7 @@ int yaffs_put_chunk_in_file(yaffs_obj_t
+@@ -2752,7 +2752,7 @@ int yaffs_put_chunk_in_file(yaffs_obj_t 
                                        NULL);
        if (!tn)
                return YAFFS_FAIL;
  #ifdef CONFIG_YAFFS_SHORT_NAMES_IN_RAM
        else if (obj->short_name[0]) {
                yaffs_strcpy(name, obj->short_name);
-@@ -4861,9 +4861,9 @@ int yaffs_set_attribs(yaffs_obj_t *obj,
+@@ -4861,9 +4861,9 @@ int yaffs_set_attribs(yaffs_obj_t *obj, 
        if (valid & ATTR_MODE)
                obj->yst_mode = attr->ia_mode;
        if (valid & ATTR_UID)
  
        if (valid & ATTR_ATIME)
                obj->yst_atime = Y_TIME_CONVERT(attr->ia_atime);
-@@ -4886,9 +4886,9 @@ int yaffs_get_attribs(yaffs_obj_t *obj,
+@@ -4886,9 +4886,9 @@ int yaffs_get_attribs(yaffs_obj_t *obj, 
  
        attr->ia_mode = obj->yst_mode;
        valid |= ATTR_MODE;
index aa3c49801636fef05b5bcc429ce31feccb43ef44..9f9690f1876625853681c0edcfc5086dc85af52c 100644 (file)
  /* LzmaDecode
 --- a/lib/lzma/LzmaDec.c
 +++ b/lib/lzma/LzmaDec.c
-@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
+@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p, 
    p->needFlush = 0;
  }
  
  {
    UInt32 dicSize;
    Byte d;
-@@ -935,7 +883,7 @@ static SRes LzmaDec_AllocateProbs2(CLzma
+@@ -935,33 +883,11 @@ static SRes LzmaDec_AllocateProbs2(CLzma
    return SZ_OK;
  }
  
 -SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
-+static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
- {
-   CLzmaProps propNew;
-   RINOK(LzmaProps_Decode(&propNew, props, propsSize));
-@@ -943,28 +891,6 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
-   p->prop = propNew;
-   return SZ_OK;
- }
--
--SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
 -{
 -  CLzmaProps propNew;
--  SizeT dicBufSize;
 -  RINOK(LzmaProps_Decode(&propNew, props, propsSize));
 -  RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
+-  p->prop = propNew;
+-  return SZ_OK;
+-}
+-
+-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
++static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
+ {
+   CLzmaProps propNew;
+-  SizeT dicBufSize;
+   RINOK(LzmaProps_Decode(&propNew, props, propsSize));
+   RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
 -  dicBufSize = propNew.dicSize;
 -  if (p->dic == 0 || dicBufSize != p->dicBufSize)
 -  {
 -    }
 -  }
 -  p->dicBufSize = dicBufSize;
--  p->prop = propNew;
--  return SZ_OK;
--}
- SRes LzmaDecode(Byte *dest, SizeT *destLen, const Byte *src, SizeT *srcLen,
-     const Byte *propData, unsigned propSize, ELzmaFinishMode finishMode,
+   p->prop = propNew;
+   return SZ_OK;
+ }
 --- a/include/linux/lzma/LzmaEnc.h
 +++ b/include/linux/lzma/LzmaEnc.h
 @@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
  void MatchFinder_Construct(CMatchFinder *p);
  
  /* Conditions:
-@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
+@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p, 
      UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
      ISzAlloc *alloc);
  void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
  {
    memmove(p->bufferBase,
      p->buffer - p->keepSizeBefore,
-@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
+@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder 
    p->buffer = p->bufferBase + p->keepSizeBefore;
  }
  
index a4331097f7bed21c2a990f26f2c4f022b3eef809..bcdc58fca85cb42dca2d9362d98ecf154b999c8c 100644 (file)
@@ -30,7 +30,7 @@
        depends on NETFILTER_ADVANCED
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -134,6 +134,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
+@@ -134,6 +134,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT) 
  obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
index ecd46b6a2b04405206ec884fb3260187e31934ad..7cb1e2af73b5e1cfcf6fbc05de01ddf81a2a37fb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -268,10 +268,34 @@ static int ct_open(struct inode *inode,
+@@ -268,10 +268,34 @@ static int ct_open(struct inode *inode, 
                        sizeof(struct ct_iter_state));
  }
  
index 11595a18dac317e72b778dbc0f7947f2523dbf0b..140889d8671cdbbd0bf4c187768cfb0ef0205a84 100644 (file)
  
        counters = alloc_counters(table);
        if (IS_ERR(counters))
-@@ -960,6 +989,14 @@ copy_entries_to_user(unsigned int total_
-                       ret = -EFAULT;
+@@ -961,6 +990,14 @@ copy_entries_to_user(unsigned int total_
                        goto free_counters;
                }
-+
 +              flags = e->ip.flags & IPT_F_MASK;
 +              if (copy_to_user(userptr + off
 +                               + offsetof(struct ipt_entry, ip.flags),
@@ -88,6 +87,7 @@
 +                      ret = -EFAULT;
 +                      goto free_counters;
 +              }
++
                for (i = sizeof(struct ipt_entry);
                     i < e->target_offset;
+                    i += m->u.match_size) {
index 3d3c6253f29bab2631bcc0ca3cc748acb1378663..db6df9a360c6c94d64679c64cd559907c71ab3d8 100644 (file)
@@ -25,7 +25,7 @@
          Ethernet bridge, which means that the different Ethernet segments it
 --- a/net/ipv6/Makefile
 +++ b/net/ipv6/Makefile
-@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
+@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o 
  obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
  
  obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
index 30c036b712ebe3eea3036d6b882d528e42238432..5b5dba50416a0b84a89feb60ea6d1f488b10c799 100644 (file)
@@ -48,8 +48,8 @@
                        return RX_HANDLER_CONSUMED; /* consumed by filter */
                } else {
 @@ -224,7 +224,7 @@ forward:
-               if (!ether_addr_equal(p->br->dev->dev_addr, dest))
-                       goto drop;
+               if (ether_addr_equal(p->br->dev->dev_addr, dest))
+                       skb->pkt_type = PACKET_HOST;
  
 -              if (NF_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
 +              if (BR_HOOK(NFPROTO_BRIDGE, NF_BR_PRE_ROUTING, skb, skb->dev, NULL,
index b3a6597a57d3bcfbd9870784ad4ce6d1a2d90706..88038d8b67ae05149d4675d66294e8e8bf9039aa 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netlink/af_netlink.c
 +++ b/net/netlink/af_netlink.c
-@@ -1503,27 +1503,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1503,27 +1503,7 @@ void netlink_detachskb(struct sock *sk, 
  
  static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
  {
index 93ff7ba71d3bddd622b8c95c3d732ea74b9aefb4..e27d0a04d6c0e6edbd61b70282ab86721d90bfd2 100644 (file)
@@ -24,7 +24,7 @@ commont qdiscs.
        }
 --- a/net/sched/sch_fifo.c
 +++ b/net/sched/sch_fifo.c
-@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
+@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff 
  
  static int pfifo_enqueue(struct sk_buff *skb, struct Qdisc *sch)
  {
index 72cff92840b4ad42f3ba66f0f9ab6fd00a873dc7..5c75194e359db5f01086b83e50afef6eb96d51a1 100644 (file)
@@ -56,7 +56,7 @@
                err = -EINVAL;
 --- a/net/ipv4/fib_semantics.c
 +++ b/net/ipv4/fib_semantics.c
-@@ -138,6 +138,10 @@ const struct fib_prop fib_props[RTN_MAX
+@@ -138,6 +138,10 @@ const struct fib_prop fib_props[RTN_MAX 
                .error  = -EINVAL,
                .scope  = RT_SCOPE_NOWHERE,
        },
index 768c80f73bab5bf819782682c5c8d26dbd10ee9c..fc032a93c974de8eced6aadee70efb3c9c2f9824 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/hostap/hostap_ap.c
 +++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2403,13 +2403,13 @@ int prism2_ap_get_sta_qual(local_info_t
+@@ -2403,13 +2403,13 @@ int prism2_ap_get_sta_qual(local_info_t 
                addr[count].sa_family = ARPHRD_ETHER;
                memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
                if (sta->last_rx_silence == 0)
index 5b8e935270cfa4f231cfd733c3a5157acd3d09c2..092ce3f0c39f349830cfdf6750374b411fb79077 100644 (file)
@@ -15,7 +15,7 @@
        default y
 --- a/drivers/pci/quirks.c
 +++ b/drivers/pci/quirks.c
-@@ -44,6 +44,7 @@ static void quirk_mmio_always_on(struct
+@@ -44,6 +44,7 @@ static void quirk_mmio_always_on(struct 
  DECLARE_PCI_FIXUP_CLASS_EARLY(PCI_ANY_ID, PCI_ANY_ID,
                                PCI_CLASS_BRIDGE_HOST, 8, quirk_mmio_always_on);
  
index 479c52d3011e764d9d8cbb960e163ca4a86be9fe..9da2648355abaa8f07597558173a293a08f2bbf9 100644 (file)
                         &fib_triestat_fops))
                goto out2;
  
-@@ -2603,17 +2605,21 @@ int __net_init fib_proc_init(struct net
+@@ -2603,17 +2605,21 @@ int __net_init fib_proc_init(struct net 
        return 0;
  
  out3:
index a177fdeddadff326c582627254397296894c6689..1d56450ae7a4b203c3054281b8c09244b3e92aaa 100644 (file)
@@ -24,7 +24,7 @@
   * All of these routines try to estimate how many bits of randomness a
   * particular randomness source.  They do this by keeping track of the
   * first and second order deltas of the event timings.
-@@ -796,6 +806,63 @@ void add_disk_randomness(struct gendisk
+@@ -796,6 +806,63 @@ void add_disk_randomness(struct gendisk 
  }
  #endif
  
index c7eb4c1c61aed0e91c84568dfb8422359603a0c7..ae81f3f384b5805ee64dcbadcaab38aaea1acf1e 100644 (file)
@@ -62,7 +62,7 @@ Signed-off-by: Vitaly Kuzmichev <vkuzmichev@mvista.com>
  {
 --- a/drivers/watchdog/mpcore_wdt.c
 +++ b/drivers/watchdog/mpcore_wdt.c
-@@ -101,9 +101,7 @@ static void mpcore_wdt_keepalive(struct
+@@ -101,9 +101,7 @@ static void mpcore_wdt_keepalive(struct 
  
        spin_lock(&wdt_lock);
        /* Assume prescale is set to 256 */