base-files: remove unnecessary early sysctl-hack
authorSteven Barth <cyrus@openwrt.org>
Tue, 11 Jun 2013 14:10:45 +0000 (14:10 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 11 Jun 2013 14:10:45 +0000 (14:10 +0000)
SVN-Revision: 36920

package/base-files/Makefile
package/base-files/files/etc/init.d/boot

index f06c12fcb52d86c74e0db3851c1d1b5be447074f..ec008c5ef069319ec9b89d083abdad1dbd65b5da 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=140
+PKG_RELEASE:=141
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 4f35eac7b35cc49f80920b89c441a44106b1b68b..d33e8ce7f8120acba81d6ec1c8db8a519e4cd756 100755 (executable)
@@ -72,11 +72,4 @@ start() {
                rootdev=$(awk 'BEGIN { RS=" "; FS="="; } $1 == "root" { print $2 }' < /proc/cmdline)
                [ -n "$rootdev" ] && ln -s "$rootdev" /dev/root
        }
-
-       # early sysctl to avoid networking races
-       if [ -d /proc/sys/net/ipv6/conf ]; then
-               for i in /proc/sys/net/ipv6/conf/*/accept_ra; do
-                       echo 0 > $i
-               done
-       fi
 }