ipq40xx: NBG6617: add usb-ledtrig-usbport to DEVICE_PACKAGES
authorChristian Lamparter <chunkeey@gmail.com>
Fri, 21 Dec 2018 18:06:49 +0000 (19:06 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 22 Dec 2018 14:08:24 +0000 (15:08 +0100)
The ZyXEL NBG6617 USB LED was not working with the default images.
It turned out that kmod-usb-ledtrig-usbport was missing from the
default installation.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ipq40xx/image/Makefile

index d95c1516533885a982b1de61af99955b186a35aa..802d30c4f55c5584fdd4ba1cbac60db7c7b4adbc 100644 (file)
@@ -236,7 +236,7 @@ define Device/zyxel_nbg6617
 #      this minimum-size. However, the larger image can be flashed both ways.
        IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k | check-size $$$$(ROOTFS_SIZE) | zyxel-ras-image separate-kernel
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | check-size $$$$(ROOTFS_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := uboot-envtools
+       DEVICE_PACKAGES := uboot-envtools kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += zyxel_nbg6617