ath10k-ct: update to version 2019-09-09
authorRobert Marko <robimarko@gmail.com>
Fri, 13 Sep 2019 10:15:39 +0000 (12:15 +0200)
committerPetr Štetiar <ynezz@true.cz>
Sun, 15 Sep 2019 20:56:09 +0000 (22:56 +0200)
Update the ath10k-ct driver version to 5e8cd86f90dac966d12df6ece84ac41458d0e95f
to enable dynamic VLANs to work. Patches refreshed during the bump.

Signed-off-by: Robert Marko <robimarko@gmail.com>
[commit description facelift]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/161-ath10k-add-support-for-configuring-management-packet.patch
package/kernel/ath10k-ct/patches/162-ath10k-fix-possible-out-of-bound-access-of-ath10k_ra.patch
package/kernel/ath10k-ct/patches/163-ath10k-fix-incorrect-multicast-broadcast-rate-settin.patch
package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
package/kernel/ath10k-ct/patches/201-ath10k-4.16_add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
package/kernel/ath10k-ct/patches/202-ath10k-4.16-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/203-ath10k-Limit-available-channels-via-DT-ieee80211-fre.patch
package/kernel/ath10k-ct/patches/976-ath10k-Check-if-station-exists-before-forwarding-tx-.patch

index 05d30891f547694b176b29a5fe7c56320aac43d0..dbf75fe1740eef31666df39c5ff56b029c229533 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2019-08-14
-PKG_SOURCE_VERSION:=9e5ab25027e0971fa24ccf93373324c08c4e992d
-PKG_MIRROR_HASH:=95dc42a5615f80528223859b4f9618feafb5a0a29a9eb4c4bc983f76c74fb535
+PKG_SOURCE_DATE:=2019-09-09
+PKG_SOURCE_VERSION:=5e8cd86f90dac966d12df6ece84ac41458d0e95f
+PKG_MIRROR_HASH:=dc1097f3a7b4b7e346918f206746d00a0b7df07ae3be9b89be55dfaef3cbbe45
 
 # Build the 5.2 ath10k-ct driver version.  Other option is "-4.19".
 # Probably this should match as closely as
index d62a1cfcf5fc78706908aa0a20eb222f44da7a82..e67003c5a79d37243fa2c60ba6956cb916b6f945 100644 (file)
@@ -43,7 +43,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
  static int ath10k_mac_get_max_vht_mcs_map(u16 mcs_map, int nss)
  {
        switch ((mcs_map >> (2 * nss)) & 0x3) {
-@@ -6388,9 +6404,10 @@ static void ath10k_bss_info_changed(stru
+@@ -6405,9 +6421,10 @@ static void ath10k_bss_info_changed(stru
        struct cfg80211_chan_def def;
        u32 vdev_param, pdev_param, slottime, preamble;
        u16 bitrate, hw_value;
@@ -56,7 +56,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
  
        mutex_lock(&ar->conf_mutex);
  
-@@ -6596,6 +6613,30 @@ static void ath10k_bss_info_changed(stru
+@@ -6613,6 +6630,30 @@ static void ath10k_bss_info_changed(stru
                                    arvif->vdev_id,  ret);
        }
  
index ab360b7261458c8de9a634b703ce5d9ef68de7c3..a24029983c55e30d78c02d4d7b55aceb7ed15f34 100644 (file)
@@ -26,7 +26,7 @@ Origin: backport, https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux
                if (ath10k_rates[i].bitrate == bitrate)
                        return hw_value_prefix | ath10k_rates[i].hw_value;
        }
-@@ -6619,22 +6619,22 @@ static void ath10k_bss_info_changed(stru
+@@ -6636,22 +6636,22 @@ static void ath10k_bss_info_changed(stru
                        return;
                }
  
index 2b550e76df7eb0e1cfd80f25ffb5b9561e7679ac..f6fd75b7e5bc38763f339bc8917fa9e1ffa026b9 100644 (file)
@@ -17,7 +17,7 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/
 
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -6404,8 +6404,8 @@ static void ath10k_bss_info_changed(stru
+@@ -6421,8 +6421,8 @@ static void ath10k_bss_info_changed(stru
        struct cfg80211_chan_def def;
        u32 vdev_param, pdev_param, slottime, preamble;
        u16 bitrate, hw_value;
@@ -28,7 +28,7 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/
        enum nl80211_band band;
        const struct ieee80211_supported_band *sband;
  
-@@ -6578,7 +6578,11 @@ static void ath10k_bss_info_changed(stru
+@@ -6595,7 +6595,11 @@ static void ath10k_bss_info_changed(stru
        if (changed & BSS_CHANGED_MCAST_RATE &&
            !WARN_ON(ath10k_mac_vif_chan(arvif->vif, &def))) {
                band = def.chan->band;
index b67ad2c3c47e17492094818d2802f491b55a7d94..aab435bccd50b7b5866045266024b57ac797a3ab 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
 
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -6600,6 +6600,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6617,6 +6617,7 @@ static void ath10k_bss_info_changed(stru
                           "mac vdev %d mcast_rate %x\n",
                           arvif->vdev_id, rate);
  
@@ -19,7 +19,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
                vdev_param = ar->wmi.vdev_param->mcast_data_rate;
                ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
                                                vdev_param, rate);
-@@ -6608,6 +6609,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6625,6 +6626,7 @@ static void ath10k_bss_info_changed(stru
                                    "failed to set mcast rate on vdev %i: %d\n",
                                    arvif->vdev_id,  ret);
  
@@ -27,7 +27,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
                vdev_param = ar->wmi.vdev_param->bcast_data_rate;
                ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
                                                vdev_param, rate);
-@@ -6634,6 +6636,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6651,6 +6653,7 @@ static void ath10k_bss_info_changed(stru
                        return;
                }
  
index 38ec21f52f95211c562dfaa2c6c65055eda30dd9..ba42fc1d2d84d5e7ca6a03da0f4ce84be7c27b5c 100644 (file)
@@ -210,7 +210,7 @@ v13:
  
  #include "htt.h"
  #include "htc.h"
-@@ -1137,7 +1138,6 @@ struct ath10k {
+@@ -1138,7 +1139,6 @@ struct ath10k {
        u32 low_5ghz_chan;
        u32 high_5ghz_chan;
        bool ani_enabled;
@@ -218,7 +218,7 @@ v13:
        bool p2p;
        bool ct_all_pkts_htt; /* CT firmware only: native-wifi for all pkts */
  
-@@ -1388,6 +1388,13 @@ struct ath10k {
+@@ -1389,6 +1389,13 @@ struct ath10k {
        } testmode;
  
        struct {
@@ -562,7 +562,7 @@ v13:
  int ath10k_wmi_attach(struct ath10k *ar)
 --- a/ath10k-4.19/wmi.h
 +++ b/ath10k-4.19/wmi.h
-@@ -3044,6 +3044,41 @@ enum wmi_10_4_feature_mask {
+@@ -3084,6 +3084,41 @@ enum wmi_10_4_feature_mask {
  
  };
  
index e5dd967a26bdc79c1a731b79b193267cb12b0fe5..0e7a03ef6d0dbcf97e59e7383235007455cd503e 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
 
 --- a/ath10k-4.19/core.h
 +++ b/ath10k-4.19/core.h
-@@ -1487,6 +1487,10 @@ struct ath10k {
+@@ -1488,6 +1488,10 @@ struct ath10k {
        u8 csi_data[4096];
        u16 csi_data_len;
  
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-4.19/mac.c
 +++ b/ath10k-4.19/mac.c
-@@ -9965,7 +9965,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9982,7 +9982,7 @@ int ath10k_mac_register(struct ath10k *a
        wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_CQM_RSSI_LIST);
  
  #ifdef CPTCFG_MAC80211_LEDS
index 3a22fc74cbb1791f7baa3c8f28279f83f1a5d1a2..d770948f79c0237a1e16a6c701a25e6f37522dc3 100644 (file)
@@ -29,7 +29,7 @@ Forwarded: https://patchwork.kernel.org/patch/10549245/
  #include <net/mac80211.h>
  #include <linux/etherdevice.h>
  #include <linux/acpi.h>
-@@ -9689,6 +9690,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -9706,6 +9707,7 @@ int ath10k_mac_register(struct ath10k *a
                ar->hw->wiphy->bands[NL80211_BAND_5GHZ] = band;
        }
  
index a2f3a3f41a70764a8ae20fbe28744d49862d988e..cd8967cb93325d99c941b09d18c926d762125f55 100644 (file)
@@ -70,7 +70,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/ath10k-5.2/htt_rx.c
 +++ b/ath10k-5.2/htt_rx.c
-@@ -2497,7 +2497,7 @@ do_generic:
+@@ -2507,7 +2507,7 @@ do_generic:
                spin_lock_bh(&ar->data_lock);
  
                peer = ath10k_peer_find_by_id(ar, peer_id);