hostapd: remove all object files on config changes
authorFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2010 18:23:06 +0000 (18:23 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2010 18:23:06 +0000 (18:23 +0000)
SVN-Revision: 19229

package/hostapd/Makefile

index 6b467961684495e8aa127b6405b544b0964a3d5b..342c7519d5c55003f7783f4a14a28780b6728b76 100644 (file)
@@ -83,9 +83,8 @@ endef
 ifneq ($(wildcard $(PKG_BUILD_DIR)/.config_*),$(subst .configured_,.config_,$(STAMP_CONFIGURED)))
   $(warning $(wildcard $(PKG_BUILD_DIR)/.config_*) != $(subst .configured_,.config_,$(STAMP_CONFIGURED)))
   define Build/Configure/rebuild
+       $(FIND) $(PKG_BUILD_DIR) -name \*.o | $(XARGS) rm -f
        rm -f $(PKG_BUILD_DIR)/hostapd/hostapd
-       rm -f $(PKG_BUILD_DIR)/hostapd/*.o
-       rm -f $(PKG_BUILD_DIR)/src/drivers/drivers.o
        rm -f $(PKG_BUILD_DIR)/.config_*
        touch $(subst .configured_,.config_,$(STAMP_CONFIGURED))
   endef