kernel/modules: location of usb-common.ko changed
authorJohn Crispin <john@openwrt.org>
Mon, 17 Nov 2014 14:30:19 +0000 (14:30 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 17 Nov 2014 14:30:19 +0000 (14:30 +0000)
usb-common.ko was moved to drivers/usb/common starting from kernel 3.16
by upstream commit f4cbd33fd5f0587910fa9db403a1b42f1cabf820

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 43290

package/kernel/linux/modules/usb.mk

index cc7092ec5aed55d7983d14360313e7e028d28a7e..74de4461fb0e2ed602933f6e6782eb1a8871599e 100644 (file)
@@ -16,9 +16,15 @@ define KernelPackage/usb-core
   TITLE:=Support for USB
   DEPENDS:=@USB_SUPPORT
   KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
+  FILES:= \
+       $(LINUX_DIR)/drivers/usb/core/usbcore.ko \
+       $(LINUX_DIR)/drivers/usb/common/usb-common.ko
+else
   FILES:= \
        $(LINUX_DIR)/drivers/usb/core/usbcore.ko \
        $(LINUX_DIR)/drivers/usb/usb-common.ko
+endif
   AUTOLOAD:=$(call AutoLoad,20,usb-common usbcore,1)
   $(call AddDepends/nls)
 endef