realtek: Use firewall4
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 28 Feb 2022 20:57:55 +0000 (21:57 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 29 Mar 2022 11:42:56 +0000 (13:42 +0200)
The realtek target is not a router, but basic device, see DEVICE_TYPE.
The basic device type does not come with firewall by default, see
include/target.mk for details. The realtek target extended
DEFAULT_PACKAGES manually with firewall.

This changes the defaults to take firewall4 and nftables instead of
firewall and iptables. This also adds the additional package
kmod-nft-offload.

The only difference to the router type is the missing ppp,
ppp-mod-pppoe, dnsmasq and odhcpd-ipv6only package.

This increases the compressed image size by about 422KBytes.

Tested-by: Stijn Segers <foss@volatilesystems.org>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/realtek/Makefile

index 1fd9a870cdb4bfb1428f094a340e81bee9f9fbec..8bed3d8a7232897e731b26931eb762c3e6ca3c85 100644 (file)
@@ -18,7 +18,7 @@ endef
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
-       firewall ip6tables iptables odhcp6c \
+       firewall4 nftables kmod-nft-offload odhcp6c \
        ip-full ip-bridge tc
 
 $(eval $(call BuildTarget))