package/kernel: move target specific modules to their own target files
authorNicolas Thill <nico@openwrt.org>
Sat, 24 Apr 2010 13:34:51 +0000 (13:34 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 24 Apr 2010 13:34:51 +0000 (13:34 +0000)
SVN-Revision: 21132

18 files changed:
package/kernel/modules/block.mk
package/kernel/modules/other.mk
package/kernel/modules/sound.mk
package/kernel/modules/spi.mk
package/kernel/modules/usb.mk
target/linux/adm5120/modules.mk [new file with mode: 0644]
target/linux/at91/modules.mk [new file with mode: 0644]
target/linux/au1000/modules.mk [new file with mode: 0644]
target/linux/avr32/modules.mk [new file with mode: 0644]
target/linux/brcm63xx/modules.mk [new file with mode: 0644]
target/linux/etrax/modules.mk [new file with mode: 0644]
target/linux/ixp4xx/modules.mk [new file with mode: 0644]
target/linux/octeon/modules.mk [new file with mode: 0644]
target/linux/ppc40x/modules.mk [new file with mode: 0644]
target/linux/ps3/modules.mk
target/linux/pxcab/modules.mk [new file with mode: 0644]
target/linux/rb532/modules.mk [new file with mode: 0644]
target/linux/rdc/modules.mk

index 85a440aa5e4050a2bfe38199cb93d917cc5edcb3..53c8ab3e99d89375b9f889c2d163370764e50053 100644 (file)
@@ -83,52 +83,6 @@ endef
 
 $(eval $(call KernelPackage,ata-artop))
 
-define KernelPackage/ata-octeon-cf
-$(call AddDepends/ata,@TARGET_octeon)
-  TITLE:=Octeon Compact Flash support
-  KCONFIG:=CONFIG_PATA_OCTEON_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_octeon_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_octeon_cf,1)
-endef
-
-define KernelPackage/ata-octeon-cf/description
-  Octeon Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-octeon-cf))
-
-
-define KernelPackage/ata-ixp4xx-cf
-$(call AddDepends/ata,@TARGET_ixp4xx)
-  TITLE:=IXP4XX Compact Flash support
-  KCONFIG:=CONFIG_PATA_IXP4XX_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_ixp4xx_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_ixp4xx_cf,1)
-endef
-
-define KernelPackage/ata-ixp4xx-cf/description
- IXP4XX Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-ixp4xx-cf))
-
-define KernelPackage/ata-rb532-cf
-$(call AddDepends/ata,@TARGET_rb532 @BROKEN)
-  TITLE:=RB532 Compact Flash support
-  KCONFIG:= \
-       CONFIG_PATA_PLATFORM \
-       CONFIG_PATA_RB532
-  FILES:=\
-       $(LINUX_DIR)/drivers/ata/pata_platform.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/ata/pata_rb532_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_platform pata_rb532_cf,1)
-endef
-
-define KernelPackage/ata-rb532-cf/description
-  RB532 Compact Flash support.
-endef
-
-$(eval $(call KernelPackage,ata-rb532-cf))
 
 define KernelPackage/ata-nvidia-sata
 $(call AddDepends/ata,)
@@ -141,21 +95,6 @@ endef
 $(eval $(call KernelPackage,ata-nvidia-sata))
 
 
-define KernelPackage/ata-magicbox-cf
-$(call AddDepends/ata,@TARGET_ppc40x)
-  TITLE:=Magicbox v2/OpenRB Compact flash support
-  KCONFIG:=CONFIG_PATA_MAGICBOX_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_magicbox_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,pata_magicbox_cf,1)
-endef
-
-define KernelPackage/ata-magicbox-cf/description
-  Support for Magicbox v2/OpenRB on-board CF slot.
-endef
-
-$(eval $(call KernelPackage,ata-magicbox-cf))
-
-
 define KernelPackage/ata-pdc202xx-old
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Older Promise PATA controller support
@@ -439,21 +378,6 @@ endef
 $(eval $(call KernelPackage,dm))
 
 
-define KernelPackage/pata-rb153-cf
-$(call AddDepends/ata,@TARGET_adm5120_router_le)
-  TITLE:=RouterBOARD 153 CF Slot support
-  KCONFIG:=CONFIG_PATA_RB153_CF
-  FILES:=$(LINUX_DIR)/drivers/ata/pata_rb153_cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,pata_rb153_cf,1)
-endef
-
-define KernelPackage/pata-rb153-cf/description
-  Kernel support for the RouterBoard 153 CF slot.
-endef
-
-$(eval $(call KernelPackage,pata-rb153-cf,1))
-
-
 define KernelPackage/aoe
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=ATA over Ethernet support
@@ -468,35 +392,6 @@ endef
 
 $(eval $(call KernelPackage,aoe))
 
-define KernelPackage/ps3vram
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=PS3 Video RAM Storage Driver
-  DEPENDS:=@TARGET_ps3||TARGET_ps3chk
-  KCONFIG:=CONFIG_PS3_VRAM
-  FILES:=$(LINUX_DIR)/drivers/block/ps3vram.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,01,ps3vram)
-endef
-
-define KernelPackage/ps3vram/description
-  Kernel support for PS3 Video RAM Storage
-endef
-
-$(eval $(call KernelPackage,ps3vram))
-
-define KernelPackage/axonram
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=Axon DDR2 memory device driver
-  DEPENDS:=@TARGET_pxcab
-  KCONFIG:=CONFIG_AXON_RAM
-  FILES:=$(LINUX_DIR)/arch/powerpc/sysdev/axonram.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,01,axonram)
-endef
-
-define KernelPackage/axonram/description
-  Kernel support for Axon DDR2 memory device
-endef
-
-$(eval $(call KernelPackage,axonram))
 
 define KernelPackage/libsas
   SUBMENU:=$(BLOCK_MENU)
index fbaf7638da3391d28bc53593fb2fb168ee2075f3..177318d4822d3a9a2107c9f553bb3f83bf9ff638 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -182,31 +182,6 @@ endef
 $(eval $(call KernelPackage,pcmcia-yenta))
 
 
-define KernelPackage/pcmcia-au1000
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=RMI/AMD Au1000 PCMCIA support
-  DEPENDS:=kmod-pcmcia-core @TARGET_au1000
-  FILES:=$(LINUX_DIR)/drivers/pcmcia/au1x00_ss.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,au1x00_ss)
-endef
-
-$(eval $(call KernelPackage,pcmcia-au1000))
-
-define KernelPackage/pcmcia-bcm63xx
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Broadcom BCM63xx PCMCIA support
-  DEPENDS:=kmod-pcmcia-core @TARGET_brcm63xx
-  KCONFIG:=CONFIG_PCMCIA_BCM63XX
-  FILES:=$(LINUX_DIR)/drivers/pcmcia/bcm63xx_pcmcia.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,41,bcm63xx_pcmcia)
-endef
-
-define KernelPackage/pcmcia-bcm63xx/description
-  Kernel support for PCMCIA/CardBus controller on the BCM63xx SoC
-endef
-
-$(eval $(call KernelPackage,pcmcia-bcm63xx))
-
 define KernelPackage/pcmcia-serial
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Serial devices support
@@ -361,43 +336,12 @@ endef
 $(eval $(call KernelPackage,mmc))
 
 
-define KernelPackage/mmc-at91
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=MMC/SD Card Support on AT91
-  DEPENDS:=@TARGET_at91 +kmod-mmc
-  KCONFIG:=CONFIG_MMC_AT91
-  FILES:=$(LINUX_DIR)/drivers/mmc/host/at91_mci.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,90,at91_mci,1)
-endef
-
-define KernelPackage/mmc-at91/description
- Kernel support for MMC/SD cards on the AT91 target
-endef
-
-$(eval $(call KernelPackage,mmc-at91))
-
-
 # XXX: added a workaround for watchdog path changes
 ifeq ($(KERNEL),2.4)
   WATCHDOG_DIR=char
 endif
 WATCHDOG_DIR?=watchdog
 
-define KernelPackage/atmel-wdt
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=AT32AP700x watchdog
-  DEPENDS:=@TARGET_avr32
-  KCONFIG:=CONFIG_AT32AP700X_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/at32ap700x_wdt.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,at32ap700x_wdt)
-endef
-
-define KernelPackage/atmel-wdt/description
- AT32AP700x watchdog
-endef
-
-$(eval $(call KernelPackage,atmel-wdt))
-
 
 define KernelPackage/softdog
   SUBMENU:=$(OTHER_MENU)
@@ -413,21 +357,6 @@ endef
 
 $(eval $(call KernelPackage,softdog))
 
-define KernelPackage/rdc321x-wdt
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=RDC321x watchdog
-  DEPENDS:=@TARGET_rdc
-  KCONFIG:=CONFIG_RDC321X_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,rdc321x_wdt)
-endef
-
-define KernelPackage/rdc321x-wdt/description
-  RDC-321x watchdog driver
-endef
-
-$(eval $(call KernelPackage,rdc321x-wdt))
-
 
 define KernelPackage/leds-gpio
   SUBMENU:=$(OTHER_MENU)
@@ -445,23 +374,6 @@ endef
 $(eval $(call KernelPackage,leds-gpio))
 
 
-define KernelPackage/ledtrig-adm5120-switch
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=LED ADM5120 Switch Port Status Trigger
-  DEPENDS:=@TARGET_adm5120
-  KCONFIG:=CONFIG_LEDS_TRIGGER_ADM5120_SWITCH
-  FILES:=$(LINUX_DIR)/drivers/leds/ledtrig-adm5120-switch.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,ledtrig-adm5120-switch)
-endef
-
-define KernelPackage/ledtrig-adm5120-switch/description
- Kernel module to allow LEDs to be controlled by the port states
- of the ADM5120 built-in ethernet switch.
-endef
-
-$(eval $(call KernelPackage,ledtrig-adm5120-switch))
-
-
 define KernelPackage/leds-net48xx
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Soekris Net48xx LED support
@@ -513,7 +425,7 @@ $(eval $(call KernelPackage,leds-alix))
 define KernelPackage/leds-wndr3700-usb
   SUBMENU:=$(OTHER_MENU)
   TITLE:=WNDR3700 USB LED support
-  DEPENDS:= @TARGET_ar71xx
+  DEPENDS:=@TARGET_ar71xx
   KCONFIG:=CONFIG_LEDS_WNDR3700_USB
   FILES:=$(LINUX_DIR)/drivers/leds/leds-wndr3700-usb.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,leds-wndr3700-usb)
@@ -770,24 +682,6 @@ endef
 
 $(eval $(call KernelPackage,input-joydev))
 
-define KernelPackage/input-rb532
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=RB532 button device support
-  DEPENDS:=+kmod-input-core @TARGET_rb532
-  KCONFIG:= \
-       CONFIG_INPUT_MISC=y \
-       CONFIG_INPUT_RB532_BUTTON
-  FILES:=$(LINUX_DIR)/drivers/input/misc/rb532_button.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,62,rb532_button)
-endef
-
-define KernelPackage/input-rb532/description
-  Kernel module for RB532 button
-endef
-
-$(eval $(call KernelPackage,input-rb532))
-
-
 define KernelPackage/mmc-atmelmci
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Amtel MMC Support
@@ -820,24 +714,6 @@ endef
 $(eval $(call KernelPackage,cs5535-gpio))
 
 
-define KernelPackage/ixp4xx-beeper
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=IXP4XX Beeper support
-  DEPENDS:=@TARGET_ixp4xx +kmod-input-core
-  KCONFIG:= \
-       CONFIG_INPUT_MISC=y \
-       CONFIG_INPUT_IXP4XX_BEEPER
-  FILES:=$(LINUX_DIR)/drivers/input/misc/ixp4xx-beeper.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,ixp4xx-beeper)
-endef
-
-define KernelPackage/ixp4xx-beeper/description
- IXP4XX Beeper support
-endef
-
-$(eval $(call KernelPackage,ixp4xx-beeper))
-
-
 define KernelPackage/textsearch
 SUBMENU:=$(OTHER_MENU)
   TITLE:=Textsearch support is selected if needed
index f2900f1319563c799545f09176810bb8c5b53c1c..3d2bd27b546cc868e819306f55c7305d6cde0c6f 100644 (file)
@@ -101,23 +101,6 @@ endef
 $(eval $(call KernelPackage,sound-i8x0))
 
 
-define KernelPackage/sound-ps3
-$(call AddDepends/sound,@TARGET_ps3||TARGET_ps3chk)
-  TITLE:=PS3 Audio
-  KCONFIG:=CONFIG_SND_PS3 \
-               CONFIG_SND_PPC=y \
-               CONFIG_SND_PS3_DEFAULT_START_DELAY=2000
-  FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
-endef
-
-define KernelPackage/sound-ps3/description
- support for the integrated PS3 audio device
-endef
-
-$(eval $(call KernelPackage,sound-ps3))
-
-
 define KernelPackage/sound-cs5535audio
 $(call AddDepends/sound,@!TARGET_uml)
   TITLE:=CS5535 PCI Controller
index ed1ab010dc9b158f85daee195d64ced4a62adc84..94c98548e9042bf507e84376d42c155126885974 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -90,21 +90,6 @@ endef
 
 $(eval $(call KernelPackage,spi-dev))
 
-define KernelPackage/bcm63xx-spi
-  SUBMENU:=$(SPI_MENU)
-  TITLE:=Broadcom BCM63xx SPI driver
-  DEPENDS:=@TARGET_brcm63xx +kmod-spi-bitbang
-  KCONFIG:=CONFIG_SPI_BCM63XX
-  FILES:=$(LINUX_DIR)/drivers/spi/bcm63xx_spi.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,92,bcm63xx_spi)
-endef
-
-define KernelPackage/bcm63xx-spi/description
-  This package contains the Broadcom BCM63xx SPI Master driver
-endef
-
-$(eval $(call KernelPackage,bcm63xx-spi))
-
 
 define KernelPackage/spi-vsc7385
   SUBMENU:=$(SPI_MENU)
index c9dc830de4cc5204e79e0a23d790141a6e2a1f5c..9a2b046de502ddbc0b71650c0cf73763313d2b4e 100644 (file)
@@ -114,50 +114,6 @@ endef
 $(eval $(call KernelPackage,usb-ohci,1))
 
 
-define KernelPackage/usb-adm5120
-$(call AddDepends/usb,@TARGET_adm5120_router_be||@TARGET_adm5120_router_le)
-  TITLE:=Support for the ADM5120 HCD controller
-  KCONFIG:=CONFIG_USB_ADM5120_HCD
-  FILES:=$(LINUX_DIR)/drivers/usb/host/adm5120-hcd.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,adm5120-hcd,1)
-endef
-
-define KernelPackage/usb-adm5120/description
- Kernel support for the ADM5120 HCD USB controller
-endef
-
-$(eval $(call KernelPackage,usb-adm5120))
-
-define KernelPackage/usb-etrax
-$(call AddDepends/usb,@TARGET_etrax)
-  TITLE:=Support for the ETRAX USB host controller
-  KCONFIG:=CONFIG_ETRAX_USB_HOST \
-       CONFIG_ETRAX_USB_HOST_PORT1=y CONFIG_ETRAX_USB_HOST_PORT2=y
-  FILES:=$(LINUX_DIR)/drivers/usb/host/hc-crisv10.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,hc-crisv10,1)
-endef
-
-define KernelPackage/usb-etrax/description
- Kernel support for the ETRAX USB host controller
-endef
-
-$(eval $(call KernelPackage,usb-etrax))
-
-define KernelPackage/usb-octeon
-$(call AddDepends/usb,@TARGET_octeon)
-  TITLE:=Support for the Octeon USB OTG controller
-  KCONFIG:=CONFIG_USB_DWC_OTG
-  FILES:=$(LINUX_DIR)/drivers/usb/host/dwc_otg/dwc_otg.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
-endef
-
-define KernelPackage/usb-octeon/description
-  Kernel support for the Octeon USB host controller
-endef
-
-$(eval $(call KernelPackage,usb-octeon))
-
-
 define KernelPackage/usb-isp116x-hcd
 $(call AddDepends/usb,@TARGET_ppc40x)
   TITLE:=Support for the ISP116x USB Host Controller
diff --git a/target/linux/adm5120/modules.mk b/target/linux/adm5120/modules.mk
new file mode 100644 (file)
index 0000000..69b8d2e
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ledtrig-adm5120-switch
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=LED ADM5120 Switch Port Status Trigger
+  DEPENDS:=@TARGET_adm5120
+  KCONFIG:=CONFIG_LEDS_TRIGGER_ADM5120_SWITCH
+  FILES:=$(LINUX_DIR)/drivers/leds/ledtrig-adm5120-switch.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,ledtrig-adm5120-switch)
+endef
+
+define KernelPackage/ledtrig-adm5120-switch/description
+ Kernel module to allow LEDs to be controlled by the port states
+ of the ADM5120 built-in ethernet switch.
+endef
+
+$(eval $(call KernelPackage,ledtrig-adm5120-switch))
+
+
+define KernelPackage/pata-rb153-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=RouterBOARD 153 CF Slot support
+  DEPENDS:=@TARGET_adm5120_router_le
+  KCONFIG:=CONFIG_PATA_RB153_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_rb153_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,pata_rb153_cf,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/pata-rb153-cf/description
+  Kernel support for the RouterBoard 153 CF slot.
+endef
+
+$(eval $(call KernelPackage,pata-rb153-cf,1))
+
+
+define KernelPackage/usb-adm5120
+  SUBMENU:=$(USB_MENU)
+  TITLE:=Support for the ADM5120 HCD controller
+  DEPENDS:=@TARGET_adm5120
+  KCONFIG:=CONFIG_USB_ADM5120_HCD
+  FILES:=$(LINUX_DIR)/drivers/usb/host/adm5120-hcd.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,adm5120-hcd,1)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-adm5120/description
+ Kernel support for the ADM5120 HCD USB controller
+endef
+
+$(eval $(call KernelPackage,usb-adm5120))
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
new file mode 100644 (file)
index 0000000..48cdef1
--- /dev/null
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/mmc-at91
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=MMC/SD Card Support on AT91
+  DEPENDS:=@TARGET_at91 +kmod-mmc
+  KCONFIG:=CONFIG_MMC_AT91
+  FILES:=$(LINUX_DIR)/drivers/mmc/host/at91_mci.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,90,at91_mci,1)
+endef
+
+define KernelPackage/mmc-at91/description
+ Kernel support for MMC/SD cards on the AT91 target
+endef
+
+$(eval $(call KernelPackage,mmc-at91))
diff --git a/target/linux/au1000/modules.mk b/target/linux/au1000/modules.mk
new file mode 100644 (file)
index 0000000..cab44aa
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/pcmcia-au1000
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RMI/AMD Au1000 PCMCIA support
+  DEPENDS:=@TARGET_au1000 kmod-pcmcia-core
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/au1x00_ss.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,au1x00_ss)
+endef
+
+$(eval $(call KernelPackage,pcmcia-au1000))
diff --git a/target/linux/avr32/modules.mk b/target/linux/avr32/modules.mk
new file mode 100644 (file)
index 0000000..7f1f0a2
--- /dev/null
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/atmel-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=AT32AP700x watchdog
+  DEPENDS:=@TARGET_avr32
+  KCONFIG:=CONFIG_AT32AP700X_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/at32ap700x_wdt.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,at32ap700x_wdt)
+endef
+
+define KernelPackage/atmel-wdt/description
+ AT32AP700x watchdog
+endef
+
+$(eval $(call KernelPackage,atmel-wdt))
diff --git a/target/linux/brcm63xx/modules.mk b/target/linux/brcm63xx/modules.mk
new file mode 100644 (file)
index 0000000..e588fe9
--- /dev/null
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/bcm63xx-spi
+  SUBMENU:=$(SPI_MENU)
+  TITLE:=Broadcom BCM63xx SPI driver
+  DEPENDS:=@TARGET_brcm63xx +kmod-spi-bitbang
+  KCONFIG:=CONFIG_SPI_BCM63XX
+  FILES:=$(LINUX_DIR)/drivers/spi/bcm63xx_spi.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,92,bcm63xx_spi)
+endef
+
+define KernelPackage/bcm63xx-spi/description
+  This package contains the Broadcom BCM63xx SPI Master driver
+endef
+
+$(eval $(call KernelPackage,bcm63xx-spi))
+
+
+define KernelPackage/pcmcia-bcm63xx
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Broadcom BCM63xx PCMCIA support
+  DEPENDS:=@TARGET_brcm63xx kmod-pcmcia-core
+  KCONFIG:=CONFIG_PCMCIA_BCM63XX
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/bcm63xx_pcmcia.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,bcm63xx_pcmcia)
+endef
+
+define KernelPackage/pcmcia-bcm63xx/description
+  Kernel support for PCMCIA/CardBus controller on the BCM63xx SoC
+endef
+
+$(eval $(call KernelPackage,pcmcia-bcm63xx))
diff --git a/target/linux/etrax/modules.mk b/target/linux/etrax/modules.mk
new file mode 100644 (file)
index 0000000..9c3bb0d
--- /dev/null
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/usb-etrax
+  SUBMENU:=$(USB_MENU)
+  TITLE:=Support for the ETRAX USB host controller
+  DEPENDS:=@TARGET_etrax
+  KCONFIG:=CONFIG_ETRAX_USB_HOST \
+       CONFIG_ETRAX_USB_HOST_PORT1=y CONFIG_ETRAX_USB_HOST_PORT2=y
+  FILES:=$(LINUX_DIR)/drivers/usb/host/hc-crisv10.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,hc-crisv10,1)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-etrax/description
+ Kernel support for the ETRAX USB host controller
+endef
+
+$(eval $(call KernelPackage,usb-etrax))
diff --git a/target/linux/ixp4xx/modules.mk b/target/linux/ixp4xx/modules.mk
new file mode 100644 (file)
index 0000000..c58881b
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-ixp4xx-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=IXP4XX Compact Flash support
+  DEPENDS:=@TARGET_ixp4xx
+  KCONFIG:=CONFIG_PATA_IXP4XX_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_ixp4xx_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,pata_ixp4xx_cf,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-ixp4xx-cf/description
+ IXP4XX Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-ixp4xx-cf))
+
+
+define KernelPackage/ixp4xx-beeper
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=IXP4XX Beeper support
+  DEPENDS:=@TARGET_ixp4xx
+  KCONFIG:= \
+       CONFIG_INPUT_MISC=y \
+       CONFIG_INPUT_IXP4XX_BEEPER
+  FILES:=$(LINUX_DIR)/drivers/input/misc/ixp4xx-beeper.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,ixp4xx-beeper)
+  $(call AddDepends/input)
+endef
+
+define KernelPackage/ixp4xx-beeper/description
+ IXP4XX Beeper support
+endef
+
+$(eval $(call KernelPackage,ixp4xx-beeper))
diff --git a/target/linux/octeon/modules.mk b/target/linux/octeon/modules.mk
new file mode 100644 (file)
index 0000000..a161d68
--- /dev/null
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-octeon-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Octeon Compact Flash support
+  DEPENDS:=@TARGET_octeon
+  KCONFIG:=CONFIG_PATA_OCTEON_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_octeon_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,pata_octeon_cf,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-octeon-cf/description
+  Octeon Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-octeon-cf))
+
+
+define KernelPackage/usb-octeon
+  SUBMENU:=$(USB_MENU)
+  TITLE:=Support for the Octeon USB OTG controller
+  DEPENDS:=@TARGET_octeon
+  KCONFIG:=CONFIG_USB_DWC_OTG
+  FILES:=$(LINUX_DIR)/drivers/usb/host/dwc_otg/dwc_otg.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-octeon/description
+  Kernel support for the Octeon USB host controller
+endef
+
+$(eval $(call KernelPackage,usb-octeon))
diff --git a/target/linux/ppc40x/modules.mk b/target/linux/ppc40x/modules.mk
new file mode 100644 (file)
index 0000000..7a12476
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-magicbox-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Magicbox v2/OpenRB Compact flash support
+  DEPENDS:=@TARGET_ppc40x
+  KCONFIG:=CONFIG_PATA_MAGICBOX_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_magicbox_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,pata_magicbox_cf,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-magicbox-cf/description
+  Support for Magicbox v2/OpenRB on-board CF slot.
+endef
+
+$(eval $(call KernelPackage,ata-magicbox-cf))
index f38ccc413442df9b83a7a5d83a25ed66127e2071..258652459f49380cb47146a690d8df763c0c7f42 100644 (file)
@@ -1,7 +1,14 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 define KernelPackage/ps3lan
   SUBMENU:=Network Devices
   TITLE:=PS3-Lan support
-  DEPENDS:=@LINUX_2_6 @TARGET_ps3
+  DEPENDS:=@TARGET_ps3
   KCONFIG:= \
        CONFIG_GELIC_NET \
        CONFIG_GELIC_WIRELESS=y
@@ -14,3 +21,38 @@ define KernelPackage/ps3lan/description
 endef
 
 $(eval $(call KernelPackage,ps3lan))
+
+
+define KernelPackage/ps3vram
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=PS3 Video RAM Storage Driver
+  DEPENDS:=@TARGET_ps3
+  KCONFIG:=CONFIG_PS3_VRAM
+  FILES:=$(LINUX_DIR)/drivers/block/ps3vram.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,01,ps3vram)
+endef
+
+define KernelPackage/ps3vram/description
+  Kernel support for PS3 Video RAM Storage
+endef
+
+$(eval $(call KernelPackage,ps3vram))
+
+
+define KernelPackage/sound-ps3
+  SUBMENU:=$(SOUND_MENU)
+  TITLE:=PS3 Audio
+  DEPENDS:=@TARGET_ps3
+  KCONFIG:=CONFIG_SND_PS3 \
+               CONFIG_SND_PPC=y \
+               CONFIG_SND_PS3_DEFAULT_START_DELAY=2000
+  FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-ps3/description
+ support for the integrated PS3 audio device
+endef
+
+$(eval $(call KernelPackage,sound-ps3))
diff --git a/target/linux/pxcab/modules.mk b/target/linux/pxcab/modules.mk
new file mode 100644 (file)
index 0000000..742cbd2
--- /dev/null
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/axonram
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Axon DDR2 memory device driver
+  DEPENDS:=@TARGET_pxcab
+  KCONFIG:=CONFIG_AXON_RAM
+  FILES:=$(LINUX_DIR)/arch/powerpc/sysdev/axonram.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,01,axonram)
+endef
+
+define KernelPackage/axonram/description
+  Kernel support for Axon DDR2 memory device
+endef
+
+$(eval $(call KernelPackage,axonram))
diff --git a/target/linux/rb532/modules.mk b/target/linux/rb532/modules.mk
new file mode 100644 (file)
index 0000000..c7ba62f
--- /dev/null
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-rb532-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=RB532 Compact Flash support
+  DEPENDS:=@TARGET_rb532 @BROKEN
+  KCONFIG:= \
+       CONFIG_PATA_PLATFORM \
+       CONFIG_PATA_RB532
+  FILES:=\
+       $(LINUX_DIR)/drivers/ata/pata_platform.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/ata/pata_rb532_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,pata_platform pata_rb532_cf,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-rb532-cf/description
+  RB532 Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-rb532-cf))
+
+
+define KernelPackage/input-rb532
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RB532 button device support
+  DEPENDS:=@TARGET_rb532
+  KCONFIG:= \
+       CONFIG_INPUT_MISC=y \
+       CONFIG_INPUT_RB532_BUTTON
+  FILES:=$(LINUX_DIR)/drivers/input/misc/rb532_button.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,62,rb532_button)
+  $(call AddDepends/input)
+endef
+
+define KernelPackage/input-rb532/description
+  Kernel module for RB532 button
+endef
+
+$(eval $(call KernelPackage,input-rb532))
index e69de29bb2d1d6434b8b29ae775ad8c2e48c5391..bb4c0cbe4e46b13278a3d3ed250704f909d888bf 100644 (file)
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/rdc321x-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RDC321x watchdog
+  DEPENDS:=@TARGET_rdc
+  KCONFIG:=CONFIG_RDC321X_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,rdc321x_wdt)
+endef
+
+define KernelPackage/rdc321x-wdt/description
+  RDC-321x watchdog driver
+endef
+
+$(eval $(call KernelPackage,rdc321x-wdt))
+