x86: avoid using grub prepare when using grub2
authorFelix Fietkau <nbd@openwrt.org>
Sun, 23 Sep 2012 09:59:56 +0000 (09:59 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 23 Sep 2012 09:59:56 +0000 (09:59 +0000)
SVN-Revision: 33525

target/linux/x86/image/Makefile

index ebe07885930a557a3b0fcfd49e3176eb3f18e68b..547f0839fdfe1a5f5fc0669cc626e41940006f70 100644 (file)
@@ -237,7 +237,7 @@ endef
 define Image/Prepare
        $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
        $(call Image/Prepare/bootscript)
-       $(call Image/Prepare/grub)
+       $(call Image/Prepare/$(if $(CONFIG_X86_USE_GRUB2),grub2,grub))
 endef
 
 define Image/Build