modules: add lz4 compression support
authorJohn Crispin <john@openwrt.org>
Wed, 28 Jan 2015 12:06:45 +0000 (12:06 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 28 Jan 2015 12:06:45 +0000 (12:06 +0000)
Signed-off-by: Nathan Hintz <nlhintz@hotmail.com>
SVN-Revision: 44169

package/kernel/linux/modules/lib.mk

index cd919ba62e9f6844bc0d45b7308b856a17d0f6f9..f230a99dff190a8bb1ca3088fbdfa428b9abccdb 100644 (file)
@@ -117,6 +117,26 @@ endef
 $(eval $(call KernelPackage,lib-lzo))
 
 
+define KernelPackage/lib-lz4
+  SUBMENU:=$(LIB_MENU)
+  DEPENDS:=@!(LINUX_3_3||LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
+  TITLE:=LZ4 support
+  KCONFIG:= \
+       CONFIG_LZ4_COMPRESS \
+       CONFIG_LZ4_DECOMPRESS
+  FILES:= \
+       $(LINUX_DIR)/lib/lz4/lz4_compress.ko \
+       $(LINUX_DIR)/lib/lz4/lz4_decompress.ko
+  AUTOLOAD:=$(call AutoProbe,lz4_compress lz4_decompress)
+endef
+
+define KernelPackage/lib-lz4/description
+ Kernel module for LZ4 compression/decompression support
+endef
+
+$(eval $(call KernelPackage,lib-lz4))
+
+
 define KernelPackage/lib-raid6
   SUBMENU:=$(LIB_MENU)
   TITLE:=RAID6 algorithm support