check if oss emulation is available before trying to package it into soundcore
authorFelix Fietkau <nbd@openwrt.org>
Mon, 16 Jul 2007 05:38:10 +0000 (05:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 16 Jul 2007 05:38:10 +0000 (05:38 +0000)
SVN-Revision: 7999

package/kernel/modules/other.mk

index d4fbd8ce61674c4bc5597644416e003ea5b912bf..fd9ade97c03fb55a7af6b4b8ce3ba1d0db99faec 100644 (file)
@@ -117,8 +117,8 @@ define KernelPackage/soundcore/2.6
   FILES:= \
        $(LINUX_DIR)/sound/soundcore.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/sound/core/*.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/sound/core/oss/*.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,soundcore snd snd-page-alloc snd-hwdep snd-rawmidi snd-timer snd-pcm snd-mixer-oss snd-pcm-oss)
+       $(if $(CONFIG_SND_MIXER_OSS)$(CONFIG_SND_PCM_OSS),$(LINUX_DIR)/sound/core/oss/*.$(LINUX_KMOD_SUFFIX))
+  AUTOLOAD:=$(call AutoLoad,30,soundcore snd snd-page-alloc snd-hwdep snd-rawmidi snd-timer snd-pcm $(if $(CONFIG_SND_MIXER_OSS),snd-mixer-oss) $(if $(CONFIG_SND_PCM_OSS),snd-pcm-oss))
 endef
 
 define KernelPackage/soundcore/uml-2.6