quilt: update to 0.60
authorLuka Perkov <luka@openwrt.org>
Tue, 24 Sep 2013 20:01:03 +0000 (20:01 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 24 Sep 2013 20:01:03 +0000 (20:01 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38170

tools/quilt/Makefile
tools/quilt/patches/000-relocatable.patch
tools/quilt/patches/001-fix_compile.patch
tools/quilt/patches/100-patch_2.6.1_version.patch [deleted file]

index 541e656affe1795e32f24b9a45a4d33ab0892821..7cd27dfe397e268e321ab5ca9e84870fb23c2a57 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 -2010 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quilt
-PKG_VERSION:=0.48
+PKG_VERSION:=0.60
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/$(PKG_NAME)
-PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
+PKG_MD5SUM:=058a08a9b626bdec9ec8c519dc92158c
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -25,7 +25,7 @@ define Host/Configure
 endef
 
 define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all lib/backup-files
+       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all
 endef
 
 define Host/Install
index f8110236a6db6923e7eb8db2dcb7d0fad7824833..dab42c2f4c15be0219b26e4fa469834ab6b74df5 100644 (file)
@@ -1,21 +1,21 @@
 --- a/bin/quilt.in
 +++ b/bin/quilt.in
-@@ -7,9 +7,15 @@
- #  See the COPYING and AUTHORS files for more details.
+@@ -11,9 +11,15 @@
+ unset POSIXLY_CORRECT
  
  export TEXTDOMAIN=quilt
 -export TEXTDOMAINDIR=@LOCALEDIR@
  
--: ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
+-: ${QUILT_DIR=@QUILT_DIR@}
 +if test -n "$STAGING_DIR"; then
 +      export TEXTDOMAINDIR="$STAGING_DIR/../host/share/locale"
 +      : ${QUILT_DIR=$STAGING_DIR/../host/share/quilt} ${QUILT_LIB=$STAGING_DIR/../host/lib/quilt}
 +else
 +      export TEXTDOMAINDIR=@LOCALEDIR@
-+      : ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
++      : ${QUILT_DIR=@QUILT_DIR@}
 +fi
 +
- export QUILT_DIR QUILT_LIB
+ export QUILT_DIR
  
  if [ -z "$QUILTRC" ]
 --- a/quilt/scripts/edmail.in
  
  if ! [ -r $QUILT_DIR/scripts/patchfns ]
  then
---- a/quilt/scripts/parse-patch.in
-+++ b/quilt/scripts/parse-patch.in
-@@ -34,7 +34,7 @@ BEGIN {
- }
- setlocale(LC_MESSAGES, "");
--bindtextdomain("quilt", "@LOCALEDIR@");
-+bindtextdomain("quilt", $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/locale' : "@LOCALEDIR@");
- textdomain("quilt");
- sub _($) {
 --- a/quilt/scripts/patchfns.in
 +++ b/quilt/scripts/patchfns.in
-@@ -10,7 +10,11 @@
+@@ -8,7 +8,11 @@
  #  See the COPYING and AUTHORS files for more details.
  
  export TEXTDOMAIN=quilt
index 51a4f5e206bb6a409a2b45eff2b5356cf8eb8251..c256c65e75dfb927997875b7bd77f2cfbbe86a5a 100644 (file)
@@ -1,7 +1,7 @@
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -273,13 +273,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
- lib/backup-files.o :: Makefile
+@@ -266,13 +266,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+       @$(if $(filter $@,$(NON_EXEC_IN)),,chmod +x $@)
  
  configure : configure.ac aclocal.m4
 -      autoconf
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
deleted file mode 100644 (file)
index 1e9ed75..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -274,7 +274,11 @@ fi
- AC_MSG_CHECKING([the version of $PATCH])
- if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
-   set -- `$PATCH --version 2> /dev/null`
--  patch_version=$2
-+  if test x$1 = xGNU ; then
-+    patch_version=$3
-+  else
-+    patch_version=$2
-+  fi
-   AC_MSG_RESULT($patch_version)
-   saved_IFS=$IFS; IFS='.'
-   set -- $patch_version