generic: fix patching error on kernel 5.4
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 8 May 2020 14:48:19 +0000 (16:48 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 8 May 2020 15:06:10 +0000 (17:06 +0200)
Fixes a build error seen when applying the kernel patches.

Applying patch generic/435-mtd-add-routerbootpart-parser-config.patch
patching file drivers/mtd/parsers/Kconfig
Hunk #1 FAILED at 160.
1 out of 1 hunk FAILED -- rejects in file drivers/mtd/parsers/Kconfig
patching file drivers/mtd/parsers/Makefile
Hunk #1 FAILED at 10.
1 out of 1 hunk FAILED -- rejects in file drivers/mtd/parsers/Makefile

This was missed as 5.4 is currently set as testing kernel
while the main kernel being used is 4.19

Fixes: 2976e423dc6e ("generic: routerboot partition build bits")
Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch

index 3ab78838b0a431febdb3096d54929d4eb6642694..4e72aa88a00e92931b52322f0c6864d02dca65b1 100644 (file)
@@ -16,23 +16,25 @@ Signed-off-by: Thibaut VARĂˆNE <hacks@slashdirt.org>
 
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -160,3 +160,12 @@ config MTD_REDBOOT_PARTS_READONLY
-         'FIS directory' images, enable this option.
+@@ -176,3 +176,12 @@ config MTD_MYLOADER_PARTS
  
- endif # MTD_REDBOOT_PARTS
+         You will still need the parsing functions to be called by the driver
+         for your particular device. It won't happen automatically.
 +
 +config MTD_ROUTERBOOT_PARTS
 +      tristate "RouterBoot flash partition parser"
 +      depends on MTD && OF
 +      help
-+        MikroTik RouterBoot is implemented as a multi segment system on the
-+        flash, some of which are fixed and some of which are located at
-+        variable offsets. This parser handles both cases via properly
-+        formatted DTS.
++       MikroTik RouterBoot is implemented as a multi segment system on the
++       flash, some of which are fixed and some of which are located at
++       variable offsets. This parser handles both cases via properly
++       formatted DTS.
 --- a/drivers/mtd/parsers/Makefile
 +++ b/drivers/mtd/parsers/Makefile
-@@ -10,3 +10,4 @@
+@@ -9,4 +9,5 @@ obj-$(CONFIG_MTD_AFS_PARTS)            += afs.o
+ obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
  obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
  obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o
- obj-$(CONFIG_MTD_MYLOADER_PARTS)      += myloader.o
+-obj-$(CONFIG_MTD_MYLOADER_PARTS)              += myloader.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS)      += myloader.o
 +obj-$(CONFIG_MTD_ROUTERBOOT_PARTS)    += routerbootpart.o