kernel: bump 5.10 to 5.10.90
authorRui Salvaterra <rsalvaterra@gmail.com>
Wed, 5 Jan 2022 13:27:56 +0000 (13:27 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 7 Jan 2022 21:30:40 +0000 (22:30 +0100)
Add and enable a new kconfig knob to disable unprivileged eBPF by default.

Patches automatically rebased.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
include/kernel-version.mk
target/linux/apm821xx/patches-5.10/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm27xx/patches-5.10/950-0355-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/generic/config-5.10
target/linux/generic/hack-5.10/204-module_strip.patch
target/linux/generic/pending-5.10/920-mangle_bootargs.patch
target/linux/kirkwood/patches-5.10/800-power-reset-linkstation-poweroff-prepare-for-new-dev.patch
target/linux/kirkwood/patches-5.10/801-power-reset-linkstation-poweroff-add-new-device.patch

index 5d462f7b06000cec1629d08e5f8f805f1e2c8e4b..677693ad085be656018990480a946561ad121b95 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .170
-LINUX_VERSION-5.10 = .89
+LINUX_VERSION-5.10 = .90
 
 LINUX_KERNEL_HASH-5.4.170 = b09f74e0cf5fc7cf5de6aa932fe654c962cb10118bdbbdddb397022c6e6d382c
-LINUX_KERNEL_HASH-5.10.89 = 92218b1a4a18f1cb9ec07d2b7fce41577452aa552c54c25b6d5fe9b4b543bb30
+LINUX_KERNEL_HASH-5.10.90 = 945e4264c014a3d9dfc0a4639309dd1ec2fb545416556421f931b95da78c2725
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index daaf46bc5f6df1d37d0525677566b367c31bf6a6..d7376abc80da58574c61142f0f3df0a65797ceaf 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -276,6 +276,7 @@ static void xhci_pci_quirks(struct devic
+@@ -279,6 +279,7 @@ static void xhci_pci_quirks(struct devic
            pdev->device == 0x0015) {
                xhci->quirks |= XHCI_RESET_ON_RESUME;
                xhci->quirks |= XHCI_ZERO_64B_REGS;
index 92a35bec922af1397308d4cfebd5d5e4926ff1b2..1d2aca4e06c8ee2ec21232afe76518e149034c7f 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -288,6 +288,7 @@ static void xhci_pci_quirks(struct devic
+@@ -291,6 +291,7 @@ static void xhci_pci_quirks(struct devic
        if (pdev->vendor == PCI_VENDOR_ID_VIA && pdev->device == 0x3483) {
                xhci->quirks |= XHCI_LPM_SUPPORT;
                xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
index 696892786eda164679e14b54cb5e3c1add23ed15..65619e083752991eaafa83dc4c7b74fd4efe3719 100644 (file)
@@ -319,7 +319,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int tx_size, err, i;
        struct ag71xx *ag;
  
-@@ -1957,10 +1956,8 @@ static int ag71xx_probe(struct platform_
+@@ -1952,10 +1951,8 @@ static int ag71xx_probe(struct platform_
        ag->stop_desc->ctrl = 0;
        ag->stop_desc->next = (u32)ag->stop_desc_dma;
  
index c37e33b13dc907ff8fbceb313f28183e4340bfd8..bd2e72e54f97937e651768f57199ca003ff15419 100644 (file)
@@ -705,6 +705,7 @@ CONFIG_BPF_JIT_DEFAULT_ON=y
 # CONFIG_BPF_PRELOAD is not set
 # CONFIG_BPF_STREAM_PARSER is not set
 CONFIG_BPF_SYSCALL=y
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
 # CONFIG_BPQETHER is not set
 CONFIG_BQL=y
 CONFIG_BRANCH_PROFILE_NONE=y
index f372687ba1c2436eb205e7651f51fce2d50d629f..645074821f22f91ca6096ee3cede2cdeb2bee3f7 100644 (file)
@@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -2337,6 +2337,13 @@ config UNUSED_KSYMS_WHITELIST
+@@ -2347,6 +2347,13 @@ config UNUSED_KSYMS_WHITELIST
          one per line. The path can be absolute, or relative to the kernel
          source tree.
  
index d8f5c06b7ee8a447aa2c7992b71a23408f05bb78..fc64a4205ef3f03208882f5eeb1940a5ce4a517c 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1790,6 +1790,15 @@ config EMBEDDED
+@@ -1800,6 +1800,15 @@ config EMBEDDED
          an embedded system so certain expert options are available
          for configuration.
  
index 03253cfe83e1188d6e1115e834eafa12f45a64a8..4b4d03839aba19ea51c13d0c6a4a9088eadd9f94 100644 (file)
@@ -15,8 +15,6 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  drivers/power/reset/linkstation-poweroff.c | 35 ++++++++++++++++++----
  1 file changed, 29 insertions(+), 6 deletions(-)
 
-diff --git a/drivers/power/reset/linkstation-poweroff.c b/drivers/power/reset/linkstation-poweroff.c
-index f1e843df0e16..8691cf98600d 100644
 --- a/drivers/power/reset/linkstation-poweroff.c
 +++ b/drivers/power/reset/linkstation-poweroff.c
 @@ -29,11 +29,21 @@
@@ -42,7 +40,7 @@ index f1e843df0e16..8691cf98600d 100644
  
        saved_page = phy_select_page(phydev, MII_MARVELL_LED_PAGE);
        if (saved_page < 0)
-@@ -66,11 +76,16 @@ static void mvphy_reg_intn(u16 data)
+@@ -66,11 +76,16 @@ err:
                dev_err(&phydev->mdio.dev, "Write register failed, %d\n", rc);
  }
  
@@ -60,7 +58,7 @@ index f1e843df0e16..8691cf98600d 100644
  
        return NOTIFY_DONE;
  }
-@@ -82,14 +97,18 @@ static struct notifier_block linkstation_reboot_nb = {
+@@ -82,14 +97,18 @@ static struct notifier_block linkstation
  static void linkstation_poweroff(void)
  {
        unregister_reboot_notifier(&linkstation_reboot_nb);
@@ -82,7 +80,7 @@ index f1e843df0e16..8691cf98600d 100644
        { },
  };
  
-@@ -97,13 +116,17 @@ static int __init linkstation_poweroff_init(void)
+@@ -97,13 +116,17 @@ static int __init linkstation_poweroff_i
  {
        struct mii_bus *bus;
        struct device_node *dn;
@@ -101,6 +99,3 @@ index f1e843df0e16..8691cf98600d 100644
        if (!dn)
                return -ENODEV;
  
--- 
-2.25.1
-
index 0b3b4ad2d7312d0c7dbc50fe769f18ff0616c164..a929aacfd03476f1a51882e13e3bf450df30b68a 100644 (file)
@@ -17,8 +17,6 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  drivers/power/reset/linkstation-poweroff.c | 43 ++++++++++++++++++++++
  1 file changed, 43 insertions(+)
 
-diff --git a/drivers/power/reset/linkstation-poweroff.c b/drivers/power/reset/linkstation-poweroff.c
-index 8691cf98600d..2a92b6052cac 100644
 --- a/drivers/power/reset/linkstation-poweroff.c
 +++ b/drivers/power/reset/linkstation-poweroff.c
 @@ -19,6 +19,7 @@
@@ -38,7 +36,7 @@ index 8691cf98600d..2a92b6052cac 100644
  struct power_off_cfg {
        char *mdio_node_name;
        void (*phy_set_reg)(bool restart);
-@@ -76,11 +79,48 @@ static void linkstation_mvphy_reg_intn(bool restart)
+@@ -76,11 +79,48 @@ err:
                dev_err(&phydev->mdio.dev, "Write register failed, %d\n", rc);
  }
  
@@ -87,7 +85,7 @@ index 8691cf98600d..2a92b6052cac 100644
  static int linkstation_reboot_notifier(struct notifier_block *nb,
                                       unsigned long action, void *unused)
  {
-@@ -109,6 +149,9 @@ static const struct of_device_id ls_poweroff_of_match[] = {
+@@ -109,6 +149,9 @@ static const struct of_device_id ls_powe
        { .compatible = "buffalo,ls421de",
          .data = &linkstation_power_off_cfg,
        },
@@ -97,6 +95,3 @@ index 8691cf98600d..2a92b6052cac 100644
        { },
  };
  
--- 
-2.25.1
-